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About This Manual 
This manual is organized into two sections. The first section is a users manual with simple 
descriptions and illustrations on how to use the SeisViewer application. The second section is a 
reference manual covering all of the features of SeisViewer, complete with detailed descriptions of 
the dialogs and parameters.   
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The SPW System 
 
Welcome to the Seismic Processing Workshop (SPW) system. SPW is a suite of applications 
written by Parallel Geoscience Corporation for processing seismic and/or GPR data. The SPW 
system was originally written for the Macintosh computer platform and has been redesigned and 
rewritten using a cross platform framework. SPW is currently available for the Windows XP, 
Windows 2000, Linux, and Macintosh PowerPC operating systems. The SPW system is composed 
of the following applications – FlowChart, Executor, SeisViewer, Tape Utility, and Vector 
Calculator. Each of these applications is also available separately. 

SeisViewer is a seismic data display and montage application. Seismic data may be displayed from 
either SEG Y format disk files or from the SPW internal processing format. Drawing tools are 
included to allow you to annotate your seismic display. You can also import bitmap graphics files 
in BMP format to build a montage of other information with your seismic display. SeisViewer 
utilizes the standard Windows print drivers commonly delivered with printers for generating 
hardcopy output. You can also generate a BMP output file for use by other graphics applications. 
An interactive tutorial of the SPW Tape Utility can be viewed at: 

http://www.parallelgeo.com/products/SPWSeisViewerIntroduction.htm. 

FlowChart allows you to build processing flows and set the parameters for processing steps. A 
simple graphical user interface reduces the learning curve and accelerates your processing time.  
An interactive tutorial of the SPW Tape Utility can be viewed at:  

http://www.parallelgeo.com/products/SPWFlowChartIntroduction.htm 

The Executor is a standalone seismic job execution engine. The Executor is multi-threaded to take 
full advantage of modern multiple CPU systems. The output of the FlowChart can be run by the 
Executor on the same system as the FlowChart or sent to a separate computer on a network. A 
single high-end system running the Executor can service multiple FlowChart client systems. This 
client-server design enables large jobs to be run on more powerful systems while user interactive 
tasks can occur on inexpensive desktop or laptop PC systems. 

Tape Utility is a data reformat, analysis, copy and verify program. As the name indicates, tape data 
handling is included in the application. All standard and many non-standard seismic data formats 
are handled in the data reformatting portion of the application. The copy and verify functions allow 
you to quickly and easily duplicate tapes for archive and/or distribution. The analysis functions 
allow you to view the contents of a tape in multiple human readable formats and enable you to 
decode the contents of the tape.  An interactive tutorial of the SPW Tape Utility can be viewed at: 

http://www.parallelgeo.com/products/SPWTapeUtilityIntroduction.htm 
The SPW Vector Calculator is a trace analysis tool that operates like a scientific calculator, using 
Reverse Polish Notation.  It can operate using scalar numbers as well as one-and two-dimensional 
vector numbers.  You may use it for simple mathematical functions, or to analyze seismic trace 
data.  You can create plots of seismic trace analyses, scale and control the annotation of these plots, 
as well as print them for reports. An interactive tutorial of the SPW Tape Utility can be viewed at:  

http://www.parallelgeo.com/products/SPWVectorCalculatorIntroduction.htm 
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Product Support 
For solutions to questions about SeisViewer, first look in this manual or consult the release notes 
file accompanying every software release.  If you cannot find answers in your documentation, 
contact Parallel Geoscience Corporation via E-mail (support@parallelgeo.com), or phone (+1-541-
412-7793).  Please be ready to provide the following information: 

• Your name. 
• Your company name. 
• The SeisViewer version you are using. 
• The operating system you are using. 
• The type of hardware you are using. 
• What you were doing when the problem occurred. 
• The exact wording of any error messages which appeared on your screen. 
• Any other pertinent data set information. 
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Warranty Disclaimer 
Parallel Geoscience Corporation’s licensors, and their directors, officers, employees, contractors or 
agents are collectively referred to herein as “PGC”.  
PGC makes no warranties, express or implied, including without limitation the implied warranties 
of merchantability and fitness for a particular purpose, regarding the software.  
PGC does not warrant, guarantee or make any representations regarding the use of, or the results of 
the use of, the software in terms of its correctness, accuracy, reliability, currentness or otherwise. 
You assume the entire risk as to the results and performance of the software. Because some 
jurisdictions do not allow the exclusion of implied warranties, the above exclusion may not apply to 
you.  

In no event shall PGC be liable to you for any consequential, incidental, or indirect damages 
(including damages for loss of business profits, business interruption, loss of business information, 
and the like) arising out of the use or the inability to use the software even if PGC has been advised 
of the possibility of such damages. Because some jurisdictions do not allow the exclusion or 
limitation of liability for consequential or incidental damages, the above limitations may not apply 
to you.  

PGC’s liability to you for actual damages from any cause whatsoever, and regardless of the form of 
the action, whether in contract, tort (including negligence), product liability or otherwise, will be 
limited to $50.  
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Introduction to SeisViewer 
 
SeisViewer is an interactive seismic data display, montage and plotting application.  SeisViewer is 
the display component of the SPW seismic processing system.  It is also stand-alone application 
capable of displaying SPW and SEGY formatted data files.  In contrast to most seismic display and 
plotting programs, SeisViewer allows you to completely customize your seismic display rather than 
forcing you to use a predefined template. The flexibility of the SeisViewer interface may require a 
slightly longer learning process but it provides you with a significantly more powerful set of tools. 
SeisViewer was designed as a Computer Aided Drafting (CAD) application for seismic data. 
Therefore, the user interface consists of a selection of drafting elements that you can place on your 
canvas with seismic displays being one of those elements. 

A typical SeisViewer Canvas. 
 
This SeisViewer introduction will guide you through the use of these drafting elements and the 
procedures necessary to build a simple seismic display.  If you are already familiar with the basic 
elements of SeisViewer you can skip the introduction and proceed directly to your topic of interest. 
The remainder of the manual is divided in to six sections: (1) A description of the Layer Tables; (2) 
A description of each of the SeisViewer commands; (3) A description of each of the SeisViewer 
display types; (4) A description of the processing capabilities found in SeisViewer; (5) A 
description of specific applications ideally performed in SeisViewer.  The final chapter contains all 
the information necessary to install SeisViewer on your computer. 
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SeisViewer opens with a blank canvas on which you place drafting elements to create a display of 
your work. 

A blank SeisViewer Canvas  
 

The Add View toolbar appears on the blank canvas when SeisViewer opens.  You may move it by 
clicking on the black bar at the top and dragging it to the desired location.  To remove it, click the 
close button located in the upper left corner. 

Add View toolbar 

 
The drafting elements on the Add View toolbar may be selected by clicking once to activate the 
element, and then pointing and clicking to position the subview.  If you point, click, and drag, you 
can determine the size of the element as you position it.  You may resize an element at any time by 
placing the cursor on any corner of the element and pushing or pulling it.  You can tell you have the 
cursor positioned properly when you see it change from a one-way arrow to a diagonal two-way 
arrow.  To reposition the element, place the cursor on any side of the element, where the cursor will 
change from a one-way arrow to a four-way arrow, and then drag the element to the desired 
position. 
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The first button on the Add View toolbar is the Select View button, which is graphically 
represented by a bold diagonal arrow.  This button is used to set the cursor for typical mouse 
functions, such as pointing and clicking for single element selection, and clicking and dragging for 
area selection.  It is also used for moving and resizing objects or subviews.  It may even be used for 
scrolling within a subview. 
 

Select View button 
 
The second button on the Add View toolbar is the Add Seismic Bitmap button. It is readily 
distinguished by a seismic wiggle.  The Add Seismic Bitmap button is the first one we will need to 
create a seismic display.   

Seismic Bitmap button 
 
To activate the Add Seismic Bitmap tool, move the cursor to the Add Seismic Bitmap button and 
click on it with your left mouse button.  Once the Add Seismic Bitmap tool is activated, move your 
cursor anywhere on the open canvas, hold down the left mouse button, and scroll out a window that 
will contain the seismic data you wish to display.  As soon as you release the mouse button, the 
Seismic Display dialog will appear showing the menu that is located under the File tab. 

Seismic Display dialog. 
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The Seismic Display dialog allows you to (1) select the format of the data files you wish to display; 
(2) select the name of the data files you wish to display; and (3) customize the display parameters 
of the data file.  SeisViewer displays both SPW and SEGY formatted data files.  To select the file 
format of the data file, scroll through the drop down menu located to the right of the words File 
format. To select the name of the seismic data file, click on the Seismic… button near the upper 
left-hand corner of the Seismic Display dialog.  The Open Data Set dialog will appear. 

Browsing to locate a seismic disk file with the Open Data Set dialog. 
 
The Open Data Set dialog allows you to maneuver through the directory structure and select the 
data file you wish to display.  Once selected, the name and the path of this file will appear 
immediately to the right of the Seismic… button.  If you attempt to select an SPW formatted file 
with the File Format selection set to SEGY, the following error message will appear: 

 

Error Message: File Extension and Format Mismatch 
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A correctly selected, SPW formatted data file. 
 
The selected seismic file may have been written to disk in a variety of sort orders.  To set the sort 
order for displaying your seismic data, configure the Primary, Secondary, and Tertiary Sort keys in 
the lower half of the Seismic Display dialog.  Each of these sort keys is set by scrolling through a 
drop down menu located to the right of the particular sort key.  In the following example, we will 
see one of many possible configurations for the display a 3D common source gather.  The sort keys 
will be set to Primary: Field File Number; Secondary: Receiver Line Number; Tertiary: Receiver 
Location Number. 

Set the Sort keys. 
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To set or review the horizontal display parameters for the seismic display, click on the Horz Axis 
tab adjacent to the File tab.  The Horizontal Axis menu displays all of the information relevant to 
(1) the spatial range of seismic data that will be displayed in the Seismic Bitmap subview, and (2) 
the horizontal size and scaling of the seismic data that will be displayed in the Seismic Bitmap 
subview.  As it is configured in the figure below, the Horizontal Axis menu indicates that the 
Seismic Bitmap subview will contain seismic traces from a range of Receiver Locations (e.g. Rx 
Loc. 118 – 239), which are located on a single Receiver Line (e.g. Rx Line 1), which was recorded 
on a single field file (e.g. FFN 3001).  However, the seismic data file selected under the File tab 
was acquired in the field with four lines of 54 receivers.  To display the data acquired with the full 
range of receivers located on each of the four receiver lines, select Plot full range in the 
Secondary range submenu.  The Trace gaps option that is checked at the bottom center of the 
Horizontal Axis menu indicates that a blank trace will be inserted between the last trace of one 
receiver line and the first trace on the subsequent receiver line.  The horizontal trace spacing can be 
adjusted by entering the desired value in the Horizontal scale parameter entry box. 
 

The Horizontal Axis menu 
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To set or review the vertical display parameters for the seismic display, click on the Vert Axis tab 
adjacent to the Horz Axis tab.  The Vert Axis menu displays all of the information relevant to (1) 
the temporal range of seismic data that will be displayed in the Seismic Bitmap subview, and (2) 
the vertical size and scaling of the seismic data that will be displayed in the Seismic Bitmap 
subview.  The Vert Axis menu allows you to set the start time of the displayed seismic data, the 
range of recording times to plot, the timing line increment, and the line style of timing lines.  As it 
is configured in the figure below, the Vert Axis menu indicates that the Seismic Bitmap subview 
will contain the full trace length (e.g. 532 samples of 2ms data for a trace length of 1062ms) of the 
data file selected under the File tab.  The vertical scale can be adjusted by entering the desired 
value in the Vertical scale parameter entry box. 

The Vertical Axis menu  
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To set or review the scaling parameters for the seismic display, click on the Scaling tab adjacent to 
the Vert Axis tab.  The Scaling menu displays all of the information relevant to the scaling of the 
seismic data that will be displayed in the Seismic Bitmap subview.  Scaling options include true 
amplitude, relative amplitude, and AGC.  The true and relative amplitude scalars can be computed 
from the full trace length or a selected time window of the data file.  As it is configured in the 
figure below, the Scaling menu indicates that each trace in the Seismic Bitmap subview will be 
scaled independently, according the maximum value found in the trace. 

The Scaling menu  
 
 .
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To set or review the trace plotting parameters for the seismic display, click on the Plot Style tab 
adjacent to the Scaling tab.  The Plot Style menu displays all of the information relevant to the style 
in which each of the seismic trace will be displayed in the Seismic Bitmap subview.  Trace plotting 
options include wiggle trace, variable area, variable area with wiggle trace, and variable density.  
The variable density display allows you the option of selecting one of several color palettes 
included with the software or of importing one of your own.  As it is configured in the figure 
below, the Plot Style menu indicates that the selected seismic data will be plotted as variable area 
wiggle traces. 
 

The Plot Style menu 
 
When you are satisfied with the preliminary plotting parameters that have been set under each of 
the previously described menus, click on the OK button in the upper left corner of the Seismic 
Display dialog.  The seismic file you selected for display will now appear on the canvas. 
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Bitmap display of a single 3D seismic field file. 
 
To annotate the horizontal or the vertical axes of this display, we need to select the appropriate 
tools from the Add View dialog.  The Add Horizontal Annotation tool in the Add View dialog is 
used place horizontal annotations on the canvas. 
 

The Add Horizontal Annotation button 
 
To activate the Add Horizontal Annotation tool, move the cursor to the Add Horizontal Annotation 
button and click on it with your left mouse button.  Once the Add Horizontal Annotation tool is 
activated, move your cursor to the upper left corner of the seismic display selected for annotation 
and you will see the cursor change from an arrow to a corner frame.   
 

Placement of the Add Horizontal Annotation tool 
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At this point, click the left mouse button and the horizontal annotation sub-window will appear. 

3D seismic field file with horizontal annotation. 
 

The Add Vertical Annotation tool in the Add View dialog is used place vertical annotations on the 
canvas. 
 

The Add Vertical Annotation button 
 
To activate the Add Vertical Annotation tool, move the cursor to the Add Vertical Annotation 
button and click on it with your left mouse button.  Once the Add Vertical Annotation tool is 
activated, move your cursor to the upper left corner of the seismic display selected for annotation 
and you will see the cursor change from an arrow to a corner frame. 

Placement of the Add Vertical Annotation tool 
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At this point, click the left mouse button and the vertical annotation sub-window will appear. 
 

3D seismic field file with vertical and horizontal annotation. 
 
To reposition the seismic display place the cursor on any of the four edges of the current display 
such that the cursor changes to a four-way arrow.  To resize the seismic display, place the cursor on 
any of the four corners of the current display such that the cursor changes to a diagonally oriented 
two-way arrow. 

 

Reposition the seismic display.                                         Resize the seismic display. 
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To add additional trace header annotation, such as the receiver elevation, we will use the Add 
Header Plot tool in the Add View dialog.  The Add Header Plot tool in the Add View dialog is used 
to create plots of trace header values on the canvas. 
 

The Add Header Plot button 
 
To activate the Add Header Plot tool, move the cursor to the Add Header Plot button and click on it 
with your left mouse button. Once the Add Header Plot tool is activated, move the cursor to the 
lower left corner of the seismic display selected for annotation, click once, and the header plot sub-
window will appear.  
 

The header plot sub-window. 
 
The Header Plot sub-window will remain empty until a trace header value is selected for display.  
To select a value, double-click in the highlighted header plot window and the Seismic Header Plot 
Display dialog will appear.  The Seismic Header Plot Display dialog allows you to select the trace 
header values for annotation as well as control the format of the displayed trace header information. 
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Seismic Header Plot Display dialog. 
 
One of the first things you should notice in the Seismic Header Plot Display dialog is that the 
seismic file from which the dialog will extract trace header information is the same as that selected 
in the Seismic Display dialog.  In other words, we are plotting header values for the seismic data 
that is currently displayed.  Second, the configuration of the sort keys in the Seismic Header Plot 
Display dialog should be identical to those set in the Seismic Display dialog. 
 
To select the trace header value that will be annotated on the seismic display, click on the Vert Axis 
tab.  The Vert Axis menu contains a drop down menu that you can scroll through to select the trace 
header field that will be annotated.  In this case, we will select Receiver Elevation. 

Selecting Receiver Elevation from the Header field list. 
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The Vertical plot range submenu in the Vert Axis menu indicates the range of receiver elevations 
that will be plotted and provides an option for flipping the y-axis such that it may go from 
minimum to maximum (e.g. 0 to 1) or visa versa (e.g. 1 to 0).  To apply the trace header selection 
to the seismic display, click on OK in the upper left corner and the Header Plot will appear on the 
canvas. 

The header plot sub-window with receiver elevations. 
 
Annotation of the header plot subwindow is performed in the same manner as the annotation of the 
seismic display.  Select the Add Vertical Annotation tool, place the cursor on one of the four 
corners of the Receiver Elevation sub-window, and click the mouse once.  Repeat this procedure a 
second time on the unannotated edge of the Receiver Elevation sub-window.   
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The header plot sub-window with annotated receiver elevations. 
 
You will notice that the Receiver Elevation annotation on the right hand side of the display is not 
properly positioned against the Receiver Elevation plot.  To left-justify the axis, double-click in this 
annotation sub-window and the Vertical Axis Display dialog will appear.  Click on At left edge in 
the Tic positions submenu under the Vert Style tab to properly position the annotation against the 
Receiver Elevation plot. 

Vertical Axis Display dialog  
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The header plot sub-window with correctly annotated receiver elevations. 
 
The final step is to annotate the canvas with a side label.  The side label should present information 
concerning fundamental aspects of the data being viewed, such as the survey name, the survey type, 
the processing history and a site map if it is available.  To add a side label click on the Add Side 
Label button in the Add View dialog.   
 

The Add Side Label button 
 
Once the Add Side Label tool is activated, move the cursor to the right-hand side of the seismic 
display, click once, and both the Drawing toolbar and the side label subwindow will appear. 
 

Add Drawing toolbar 
 

The Drawing toolbar contains a selection drawing elements that may be placed in the side label 
subwindow.  Each of these drawing elements is activated in the same manner as those in the Add 
View toolbar. 
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The side label subwindow. 
 
The side label subwindow can contain several text boxes.  To add the first text box, activate the 
Multi-line Text tool on the Add Drawing toolbar by selecting the appropriate button.   
 

The Add Multi-line Text button 
 
Once the Multi-line Text tool has been activated, place the cursor in the side label subwindow and 
click once on the left mouse button.  A text window will appear. 
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A Multi-Line Text Object 
 
Double click in the text window and the Multi-Line Text Object dialog will appear. 
 

The Multi-Line Text Object dialog 
 
To fill the current Multi-line text object with the processing history, simply click on the Append 
button located in the lower left of the dialog, customize the font size if you care to, and click on the 
OK button in the upper left corner.  Each of the processing steps you have applied to the data will 
appear in the text box.  The box can be resized by positioning the cursor over one of the red squares 
at each of the four corners of the text box, and pushing or pulling the box to the desired dimension.   
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To add additional text boxes, reactivate the Multi-line text tool, click in the side label, and type the 
desired information.  When your side label is done it will look something like this: 

 

Fully annotated display of a 3D common shot gather. 
 
Once the SeisViewer canvas contains all of the information required in your seismic display, you 
will want to save the canvas.  This is a simple matter of selecting the Save Canvas command under 
the File menu.  At this point the Enter Output Canvas Filename dialog will appear.    
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Selecting Save Canvas from the File menu. 
 

Naming a Seisviewer canvas file with the Enter Output Canvas Filename dialog. 
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The Enter Output Canvas Filename dialog allows you to maneuver through the file structure, select 
an output directory for the SeisViewer canvas, and assign a file name to the SeisViewer canvas.  
Once selected, the file name of the SeisViewer canvas will appear in parenthesis immediately to the 
right of the SeisViewer icon located in the upper left corner of the SeisViewer display.  The .can 
extension is automatically appended to the chosen file name. 

Saved SeisViewer Canvas 
 
The saved SeisViewer file contains all of the display parameters that were set during creation of the 
canvas.  Therefore, to view the same seismic display in the future, simply select Open Canvas from 
the File menu and select the appropriate SeisViewer canvas file name.   
 
Use the scroll keys on your keyboard to scroll through each of the field files in the selected data set.  
The up arrow will step forward one field file at a time, and the down arrow will step backward one 
field file at a time. 
 
This concludes the SeisViewer introduction.  You should now have an elementary understanding of 
how seismic displays are created in SeisViewer. 
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Templates   
 
 
SeisViewer templates are read-only files that were designed to serve as examples of common 
SeisViewer canvases in which you view, analyses, and process data.  A text file accompanies each 
SeisViewer canvas template that explains the purpose of the canvas, indicates how to use the 
canvas, and describes the inputs and outputs required by the canvas.  A zip file (Templates.zip) 
containing a complete range of SeisViewer and FlowChart templates is available as a free 
download from the Parallel Geoscience web site at: 
 

ftp.parallelgeo.com/SPW_Products/Windows/Beta_Release/ 
 
The path name of each file in Templates.zip is specified relative to the pgc directory, which is 
C:\Program Files\pgc.  Therefore, if you will want to extract the entire contents of the zip file to the 
C:\Program Files\pgc directory.   The next few pages will explain how to access and implement the 
template for viewing Field Files.  
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Example Template: Field File QC 
 
 
To access the Field File QC template, select Open Templates from the File menu. 

 
 

Step 1: select Open Template… from the File menu. 
 
 
Selection of the Open Templates… will launch a dialog box that will prompt you to select a 
particular template.     
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The SeisViewer templates. 
 
 
We are looking for the processing template that displays fully-annotated Field Files, so we will 
select the file Field File QC.tms, which is the SeisViewer template file (*tms) for the display of 
Field Files.    A SeisViewer canvas and its accompanying text file will open on the screen. 

The canvas Field File QC.tms and the accompanying text file. 
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SeisViewer templates, such as Field File QC.tms are read-only files that can be neither altered nor 
interacted with.  However, you may use the file by saving it as a new file and assigning the 
appropriate inputs and outputs.  In the case of Field File QC.tms, this would involve saving the file 
to a new directory (i.e. C:\My Project) and assigning the file a new name (i.e. Field File QC.can).  
You would then associate a data file with the seismic bitmap by double-clicking on the seismic 
bitmap and using the Seismic… button to located under the File tab to assign the data set you wish 
to display.  Once the file has been renamed the seismic file has been re-assigned, the canvas is 
ready for viewing. 
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Layer Table 
 
In order to increase the flexibility of the seismic display, each subview in a SeisViewer canvas is 
treated as an individual layer.  For example, the final canvas in the SeisViewer introduction 
consisted of eight layers: (1) a seismic bitmap; (2) a horizontal annotation for the seismic bitmap; 
(3-4) two vertical annotations for the seismic bitmap; (5) a trace header plot; (6-7) two vertical 
annotations for the trace header plot; (8) a side label.  The Layer Table is designed to centralize 
control of all subview-related functions on the SeisViewer canvas.  First, it allows you to access 
and control each of the individual subview parameter dialogs.  Second, it allows you to access and 
control the spatial relationship between individual subviews.  Third, it allows you to establish links 
between individual subviews so that they will act separately or in unison.  An example will serve to 
demonstrate the utility of the Layer Table functions. 
 
The SeisViewer canvas in the figure below compares a 3D shot gather before (left) and after (right) 
the application of datum statics.  Each of the seismic displays is complete with horizontal, vertical, 
and trace header annotation. Each of these elements constitutes a layer on the canvas.  The Layer 
Table displays entries such as the file name, the data group, and the horizontal and vertical 
relationships existing among each of the subviews.  The remainder of this chapter will describe the 
information content of the Layer Table associated with this canvas as well as the Layer Table 
commands used to modify the canvas’s appearance.   
 

Seismic display comparing a 3D shot gather before (left) and after (right) datum statics. 
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To access the Layer Table select Layer Table from the Window submenu.  The Layer Table will 
appear in the foreground, and the main menu on the top of the canvas will change from the 
SeisViewer menu to the Layer Table menu. 
 

Accessing the Layer Table 
 

The Layer Table (foreground) and the Layer Table menu (upper left corner). 
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A first look at the Layer Table presents the user with a spreadsheet of subview related information.  
In this case, the type icons in the first column of the Layer Table indicate that there are two seismic 
bitmap subviews, two header plot subviews, two horizontal annotation subviews, and eight vertical 
annotation subviews.  Layer numbers in the second column of the Layer Table are assigned 
sequentially, in the order in which the subview appeared on the canvas. To select a subview or to 
identify the subview corresponding to any individual layer, simply select a layer in the Layer 
Table.  The corresponding subview will be highlighted with a cyan boarder. 

 

Identification of a layer with the corresponding subview. 

Specific elements of the layer table for the shot gather comparison. 
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The next four sections will be dedicated to (1) defining each of the fields in the Layer Table 
spreadsheet; (2) describing each of the commands in the Layer Table menu; (3) describing the 
Layer Table Editing features; (4) describing the Layer Table Sorting features.  The final section 
will be an interpretation of the Layer Table contents for the SeisViewer canvas illustrated in the 
previous figures. 
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Layer Table Spreadsheet 
 
Subview 
 

Type 
The icon denoting the type of subview is for information purposes only.  It cannot be changed 
or edited. A single mouse click on the icon will select the subview.  A double click will raise 
the parameter dialog for that subview. 
 
Layer  
All subviews must have a layer number.  The layer value for a subview represents its 
placement in the canvas drawing order. Layer numbers are assigned sequentially, in the order 
in which the subview appears on the canvas.  A subview with a higher layer value can obscure 
one with a lower value if they overlap.  Editing the layer number is discussed under Editing 
Layer Table Items. 
 
Name 
The subview name is intended to be a unique name by which each specific subview may 
identified. Subview names are assigned alphabetically, in the order in which they appear on the 
canvas.  Editing of the subview name is not allowed.  

 
Data 
 

Filename 
The Filename lists the name of the data file associated with that subview. If no data file is 
opened for a subview, the Filename column will be empty. The filename corresponding to a 
particular subview may be changed in one of two ways. First, to change the data file 
corresponding to a Seismic Bitmap, a Header Plot, or the Horizontal or Vertical Axis subview 
of a Seismic Bitmap, double click on the Filename text to raise the file dialog page, where you 
may open a different data file or close the current one.  Second, to change the data file 
corresponding to a Drawing Image or Side Label subview, change the name of the data group 
to that of a subview associated with the desired data file.  Double clicking on the Filename of a 
Drawing Image or Side Label subview will only bring up its environment page, not a file 
dialog.  The name of the data file cannot be changed from the environment page.  
 
Group 
Subviews belonging to the same data group are associated with the same data file.  Therefore, 
they will display information relating to the same data. 
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Scroll Group 
The purpose of a scroll group is to allow synchronous horizontal or vertical movement either 
among subviews of an individual data group or among subviews of different data groups. 

 
 
 
Horizontal 
Seismic bitmap subviews that belong to the same horizontal scroll group will stay 
synchronized as any one of those subviews is stepped through by primary, secondary, or 
tertiary sort keys.  Subviews that belong to both the same data group and the same horizontal 
scroll group will change sorting parameters, horizontal scales, and vertical scales together.  
 
Vertical 
Subviews that belong to the same vertical scroll group will stay synchronized when any one of 
the subviews is dragged or scrolled in the vertical direction.  They will also change vertical 
scales together.  

 
Edge Group 
The purpose of an edge group is to allow simultaneous movement of all edges in that group in the 
same direction and by the same amount. When subviews are created such that they share a 
common boundary (i. e. "snap to" one another), those edges are automatically assigned to a 
common edge group.  When subviews are created such that they have an edge that would be 
common except for a small gap along the dimension perpendicular to those edges, those edges are 
also assigned to a common edge group. 
 

Left 
Subviews that share a common left edge group will move in unison. 
 
Right 
Subviews that share a common right edge group will move in unison. 
 
Top 
Subviews that share a common top edge group will move in unison. 
 
Bottom 
Subviews that share a common bottom edge group will move in unison. 
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Fixed Size 
The fixed size fields Width and Height are toggle switches that change state between True and 
False with a single mouse click. These characteristics determine whether the width and/or the 
height of a subview will be preserved during a resize or a translation of the associated subview. 
Take the example of two side-by-side subviews that share a common border.  If Width is True for 
the right-hand subview, resizing the left-hand subview by moving the common border either left or 
right will not change the width of the right-hand subview. The right edge of the right-hand subview 
will move in the same sense and the same amount as the common boundary (its left edge), 
preserving the width of the right-hand subview. 
 

Width 
A value of True indicates that the width of the subview will be preserved during a resize or a 
translation of the associated subview. A value of False indicates that the width of the subview 
will not be preserved during a resize or a translation of the associated subview. 
 
Height 
A value of True indicates that the height of the subview will be preserved during a resize or a 
translation of the associated subview. A value of False indicates that the height of the subview 
will not be preserved during a resize or a translation of the associated subview. 
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Layer Table Menu 
 
File Menu 
 

Hide Window 
Selection of the Hide Window command will hide the Layer Table window and bring the 
SeisViewer window into the foreground.  

 
Exit 
Exit shuts down the SeisViewer application. If the current canvas is newly created, or canvas 
has been changed since it was last saved, a warning dialog will appear that asks you to save 
these files prior to shut down.  

 
Edit Menu 
 

Select All Views 
The Select All Views command will select all views contained in the SeisViewer window. 
(The highest layer will be designated as the current subview.)  

 
Delete View 
The Delete Views command will delete all selected subviews.  A warning dialog will appear 
asking for verification. Once deleted, subviews cannot be retrieved unless they were saved 
previously to the existing canvas.  The Delete View command may also be accessed through 
the keyboard combination Crtl+Del. 

 
View Menu 
 

Hide Selected Views 
The Hide Selected Views command will hide all selected subviews in the SeisViewer window. 
The subviews will still exist, and all of their settings will be preserved. The hidden subview 
will be listed in the Layer Table in grayed out text (or whatever color has been selected for 
"Hidden subview text" in the Preferences… dialog found under the Edit submenu.)  
 
Show Selected Views 
The Show Selected Views command will reveal any hidden subviews that are selected in the 
Layer Table.  Hidden subviews are listed in the Layer Table in grayed out text (or whatever 
color has been selected for "Hidden subview text" in the Preferences… dialog found under the 
Edit submenu.)  

 
Opaque Background 
The Opaque Background command is used to set all selected subview backgrounds opaque. 
When a subview has an opaque background, it will obscure all subviews that it overlays. By 
default, Seismic Bitmap and Side Label subviews are created with opaque backgrounds.  
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Transparent Background 
The Transparent Background command is used to set all selected subview backgrounds 
transparent. When a subview has a transparent background, any subviews that it overlays will 
be visible. By default, Drawing Image, Header Plot, Horizontal Annotation, and Vertical 
Annotation subviews are created with transparent backgrounds.  
 
Draw Border 
The Draw Boarder command will draw a border for all selected subviews.  The border will be 
beveled for all subviews except Side Labels, which have a solid border.  Default colors for the 
beveled border are off white and gray, but these may be reset in the Preferences… dialog's 
found under the Edit menu. By default the Seismic Bitmap, Header Plot, Drawing Image, and 
Side Label subviews are created with a border.  
 
No Border 
The No Boarder command will remove the border from all selected subviews. By default, 
Horizontal and Vertical Annotation subviews are created without a border.  

 
Window Menu 
 
The Window Menu is used to access application windows other than the Layer Table window. 
(Currently only the SeisViewer and the Layer Table windows are available.)  
 

Canvas 
This command will bring the SeisViewer window to the front of the window stack, and place 
the Layer Table in the background.  

 
Help Menu 
 

About... 
The About… command lists the SeisViewer version number and information about Parallel 
Geoscience Corporation. 
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Editing Layer Table Items 
 
The elements in the Layer Table that may be edited are: the layer number, the data file name, the 
data group name, the two scroll group names, the four edge group names, and the states of the 
width and the height fields. The width and the height fields toggle between true and false with a 
single mouse click on the text.  To change the data file name corresponding to a Seismic Bitmap, a 
Header Plot, or the Horizontal or Vertical Axis of a Seismic Bitmap, double click on the Filename 
text to raise the file dialog page, where you may open a different data file or close the current one.  
The values associated with a layer number, a data group, a scroll group, or an edge group may be 
edited manually or with the drag-and drop feature. 
 

Manual Editing 
To perform a manual edit, double click with the mouse on the target text. This will cause the 
row for that subview will be highlighted in cyan and the target text to be highlighted in white.  
Edit the target text with the keyboard, making sure to input the value with the Enter key. 

 
Drag-and-Drop Editing 
Drag-and-drop editing is performed by selecting a desired value with the mouse and dragging 
it to the target element. When the mouse button is held down over a draggable element, the text 
background of that element will be highlighted in magenta. When the mouse is moved to a 
valid target location, the text of the target element will become highlighted in magenta.  To 
drop the dragged element into a highlighted target text location, simply release the mouse 
button and the target element will change to the value of the dragged element.  
 

Drag-and-drop editing of layer values, data group names, and scroll group names is only allowed 
in the same column as the target element.  Drag-and-drop editing the Right and the Left edge 
group names is allowed between the two columns. Drag-and-drop editing the Top and the Bottom 
edge group names is allowed between the two columns. Drag-and-drop editing is not allowed for 
Type icons, Subview names, Data Filenames, or the Width and Height fields. 
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Sorting the Layer Table 
 
The Layer Table lists all the existing subviews of the canvas in a sorted order, each row of the 
table representing one subview. Initially the table is sorted by drawing order or "layer", denoted by 
the highlighted Layer button. When sorting by layer, the most recently added subview will be at 
the top of the table (that with largest layer value at the top of the stack), and the remaining 
subviews will be listed in decreasing layer value (toward the bottom of the stack.).  The Layer 
Table may be sorted by all fields with the exception of the Width and the Height fields. To sort the 
Layer Table according to a given field, simply depress the appropriate button at the top of the 
column with the mouse.  The column button will become highlighted.  
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Reading a Layer Table 
 
Now that the fields and the commands related to the Layer Table have been defined, we will 
quickly read the layer table in associated with the example. 
 

Example Layer Table. 
 
The example Layer Table in the figure above consists of fourteen layers: two seismic bitmaps 
(1,8); two header plots (5,12); two horizontal annotations for the seismic bitmaps (2,9); four 
vertical annotations for the seismic bitmaps (3,4,10,11); four vertical annotations for the trace 
header plots (6,7,13,14). 
 
The subviews on the SeisViewer canvas are associated with two seismic data files, 
RussPermGeom and RussPermDatum.  The RussPermGeom file consists of trace header updated 
field files prior to the application of datum statics, and the RussPermDatum file consists of trace 
header updated field files after to the application of datum statics.  These data files have been 
assigned the Group names A and I, respectively. 
 
The two seismic bitmaps, the two trace header plots, and the two horizontal annotations for the 
seismic bitmaps are all assigned to Horizontal Scroll Group F.  This implies that as we step 
through the shot gather on the left (i.e. RussPermGeom), the shot gather on the right (i.e. 
RussPermDatum), each of the horizontal annotations, and the each of the trace header plots will 
advance in unison.  The same is true if we step through the shot gather on the right: the associated 
layers in the Horizontal scroll group will follow in unison.  Because we are comparing to sets of 
seismic data one shot gather at a time, this is exactly what we want. 
 



 46 

The two seismic bitmaps and the four vertical annotations for those seismic bitmaps are all 
assigned to Vertical scroll group B.  This links both of the seismic data files and they’re 
corresponding vertical timing lines.  Dragging or scrolling any one of these layers in the vertical 
direction will result in an equal movement among the associated layers in the Vertical scroll group. 
 
As the Layer Table is currently configured, each of the seismic bitmaps share an edge group with 
the horizontal annotations on their top edge, the trace header plots on their bottom edge, and the 
vertical annotations along each of their side edges.  In particular, the seismic bitmap in Layer 1, 
which is on the right side of the canvas, belongs to Left edge group D, Right edge group G, Top 
edge group C, and Bottom edge group E.  The horizontal annotation in Layer 2, which is on top of 
the seismic bitmap in Layer 1, belongs to Bottom edge group C.  Therefore, edge group C links the 
top edge of the seismic bitmap and the bottom edge of the associated horizontal annotation.  
Working your way around the seismic bitmap in a clockwise direction, you will see that each edge 
of the seismic bitmap is linked to the adjacent layer through an edge group.   
 
As the Layer Table is currently configured there are vertical links between the two seismic bitmaps 
through Top and Bottom edge groups C and E.  In other words, if we were to move the shot gather 
display corresponding to the seismic bitmap in Layer 1 towards the top of the canvas, the shot 
gather display corresponding to the seismic bitmap in Layer 8 would follow.  However, there are 
no horizontal links between the two seismic bitmaps and their associated annotations.  In other 
words, if we were to move the shot gather display corresponding to the seismic bitmap in Layer 1 
to the left, the shot gather display corresponding to the seismic bitmap in Layer 8 would not 
follow.  To link the two displays horizontally, we need to place their horizontal edges – the right 
edge of the vertical annotation in Layer 4 and the left edge of the vertical annotation in Layer 10 - 
in the same edge group.  To link the right edge of the vertical annotation in Layer 4 and the left 
edge of the vertical annotation in Layer 10 simply drag-and-drop Right edge group T in Layer 4 
into Left edge group N in Layer 10.  The seismic bitmaps and their associated annotations are now 
linked sequentially, horizontally, and vertically. 
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Selection of Right edge group T. 
 

Dragging Right edge group T to Left edge group N.  
 

Dropping Right edge group T into Left edge group N. 
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The Width and Height fields state whether the size of a subview will remain fixed during a resize 
or a translation.  As the Layer Table is currently configured neither of the two seismic bitmaps nor 
the two header plots is set to be fixed during a resize or a translation.  The effect of these Fixed 
Size states is demonstrated by dragging the seismic display on the right of the canvas up and to the 
left.  The height/width ratio of the dragged canvas will remain unchanged during after translation.  
However, the height/width ratio of the seismic display on the left and of the two trace header plots 
will be distorted by an amount proportional to the magnitude of translation.  In order to translate or 
resize the seismic display on the right without a corresponding distortion of the other plots, simply 
toggle the height and width fields associated with the trace header plots and the seismic display on 
the left to “True”. 

Grab the seismic display on the right and drag up and to the left. 
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Translation of the seismic bitmap on the right with “False” height and width fields for the 
seismic bitmap on the left and “False” height and width fields for the two trace header plots. 

 
 

Toggle each of the Width and Height fields associated with the trace header plots in Layers 
5 and 12 and the seismic bitmap in Layer 8 to “True”. 
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Translation of the seismic bitmap on the right with “True” height and width fields for 
both seismic bitmaps and the corresponding trace header plots. 
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SeisViewer Commands 
 
This chapter describes each of the commands that are accessed through the main menu of the 
SeisViewer canvas.  The most commonly used commands may also be accessed though one of 
three toolbars that contain the commands located under the Add View, Picking, and Drawing 
submenus. 
 
 
 

A blank SeisViewer Canvas with the Add View, Picking, and Drawing toolbars.  
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File Menu 

File Menu 
 
 
New – Selection of the New command creates a blank SeisViewer Canvas.  If you select this 
command while you are in the process of creating a SeisViewer canvas or while you are viewing a 
previously created SeisViewer canvas, Seisviewer will automatically launch a dialog asking if you 
want to save the current canvas.  Any unsaved work will be lost. 
 
Open Canvas …  - Selection of the Open Canvas command opens the Enter Input Canvas 
Filename dialog.  The Enter Input Canvas Filename dialog allows you to maneuver through the 
operating systems directory structure and select the previously created SeisViewer canvas you wish 
to display.  Once selected, the name of this canvas will appear in parenthesis immediately to the 
right of the SeisViewer Canvas text in the upper left corner of the canvas. 
 
Close - Selection of the Close command closes the current SeisViewer canvas.  If the canvas you 
are working on contains unsaved elements, Seisviewer will automatically launch a dialog asking if 
you want to save the current canvas.  Any unsaved work will be lost. 
 
Save Canvas - Selection of the Save Canvas command will save all of the display parameters in 
the current SeisViewer canvas. 
 
Save Canvas As … - Selection of the Save Canvas As command opens the Enter Input Canvas 
Filename dialog and allows you to save the current canvas under a different file name, a different 
file directory, or both. The Enter Input Canvas Filename dialog allows you to maneuver through the 
operating systems directory structure and rename the current canvas.  Once selected, the name of 
the new canvas will appear in parenthesis immediately to the right of the SeisViewer Canvas text in 
the upper left corner of the canvas.  The Save Canvas As command is equivalent to renaming the 
file. 
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Export Image …  - The Export Image command is used to output a bitmap file of the current 
canvas.  
 
Page Setup … - The Page Setup command is used to select the name and properties of the current 
printer, the paper size used in that printer, and the orientation of the document to be printed. 
 
Print … - The Print command is used to print the current document to the printer selected in Page 
Setup. 
 
Print Window … - The Print Window command is not currently active. 
 
 
 
 
Start Executor …  - The Start Executor command is used to remotely launch the Executor. Once 
launched, the Executor will execute all binary compile files currently residing in the default target 
directory for compile files. 
 
Start FlowChart … - The Start FlowChart command is used to remotely launch the SPW 
FlowChart application. 
 
Start Tape Utility - The Start Tape Utility command is used to remotely launch the SPW Tape 
Utility application. 
 
Start VCalc ++ - The Start VCalc ++ command is used to remotely launch the SPW Vector 
Calculator application. 
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Edit Menu 
 

Edit Menu 
 
 
 
Delete Point – The Delete Point command is used to delete time and semblance picks from the 
SeisViewer Canvas. 
  
Delete Object  - The Delete Object command is used to delete side label and drawing objects from 
the SeisViewer Canvas. 
 
Delete View - The Delete View command is used to remove time and semblance picks from the 
SeisViewer Canvas. 
 
 
 
 
Select All Views - The Select All Views command is used to actively select all of the views – 
visible and hidden – currently on the canvas. 
 
 
 
 
Preferences – The Preferences command opens the Preferences dialog.  The Preferences dialog is 
used to set a number of screen and export parameters for the SeisViewer display, including screen 
units (inches or centimeters), screen resolution, the color of various screen items, the orientation 
and resolution of exported bitmap files, print margins, and plot sizes. 
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Add View 

Add View Menu 
 
 
 
Select – The Select command activates the Select tool.  Once activated, the Select tool is allows the 
cursor to be used for typical mouse functions, such as pointing and clicking to select a single 
subview, or clicking and dragging to move or resize objects or subviews.  The Select tool is also 
used to scroll within a subview by holding down the left mouse button, and dragging the seismic or 
grid display to a desired location.  The Select tool is readily accesses through the Add View 
toolbar. 
 
Seismic Bitmap – The Seismic Bitmap command activates the Add Seismic Bitmap tool.  Once 
activated, the Add Seismic Bitmap tool allows you to move your cursor anywhere on the open 
canvas, hold down the left mouse button, and scroll out a window that will contain the seismic data 
you wish to display.  As soon as you release the mouse button, the Seismic Display dialog will 
appear.  Click on the Seismic … button in the Seismic Display dialog to select the desired seismic 
file. The Seismic Bitmap tool is readily accesses through the Add View toolbar. 
 

 Grid – The Grid command activates the Add Grid tool.  Once activated, the Add Grid tool allows 
you to move your cursor anywhere on the open canvas, hold down the left mouse button, and scroll 
out a window that will contain the grid data you wish to display.  As soon as you release the mouse 
button, the Grid Display dialog will appear.  Click on the Source … button in the Grid Display 
dialog to select the desired grid file.  The Add Grid tool is readily accesses through the Add View 
toolbar. 

 
 Horizontal Annotation – The Horizontal Annotation command activates the Add Horizontal Axis 

tool.  Once activated, the Add Horizontal Axis tool allows you to add horizontal annotation to a 
seismic or grid display by placing the cursor at a corner of the respective display, and clicking once 
with the left mouse button.  The Horizontal Axis tool is readily accesses through the Add View 
toolbar. 
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Vertical Annotation – The Vertical Annotation command activates the Add Vertical Axis tool.  
Once activated, the Add Vertical Axis tool allows you to add vertical annotation to a seismic or 
grid display by placing the cursor at a corner of the respective display, and clicking once with the 
left mouse button. The Vertical Axis tool is readily accesses through the Add View toolbar. 
 
Drawing Image – The Drawing Image command activates the Add Drawing Image tool.  Once 
activated, the Add Drawing Image tool allows you to move your cursor anywhere on the open 
canvas, hold down the left mouse button, and scroll out a window that will contain non-seismic 
annotations. The drawing image window may contain text, drawings, and imported bitmap images.  
The Add Drawing Image tool is readily accesses through the Add View toolbar. 
 
Side Label – The Side Label command activates the Add Side Label tool. Once activated, the Add 
Side Label tool allows you to move your cursor anywhere on the open canvas, hold down the left 
mouse button, and scroll out a window that will contain the side label you wish to create. The side 
label window may contain text, drawings, imported bitmap images, and the processing history of 
the corresponding seismic data.  The Add Side Label tool is readily accesses through the Add View 
toolbar. 
 
Header Plot – The Header Plot command activates the Add Header Plot tool. Once activated, the 
Add Header Plot tool allows you to annotate a seismic display with a plot of corresponding trace 
header values by placing the cursor at a corner of the display, and clicking once with the left mouse 
button.  The Add Header Plot tool is readily accesses through the Add View toolbar. 
 
Color Bar – The Color Bar command activates the Add Color Scale tool. Once activated, the Add 
Color Scale tool allows you to add a color scale to a seismic or grid display by placing the cursor at 
a corner of the respective display, and clicking once with the left mouse button.  The Add Color 
Scale tool is readily accesses through the Add View toolbar. 
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Step 

Step Menu 
 
 

 
Next Primary – The Next Primary command causes the selected seismic bitmap subview to step 
forward one unit in accordance with the header field set as the primary sort key under the File tab 
of the Seismic Display dialog. 
  
Previous Primary – The Previous Primary command causes the selected seismic bitmap subview 
to step backward one unit in accordance with the header field set as the primary sort key under the 
File tab of the Seismic Display dialog. 
 
Next Secondary – The Next Secondary command causes the selected seismic bitmap subview to 
step forward one unit in accordance with the header field set as the secondary sort key under the 
File tab of the Seismic Display dialog. 
 
Previous Secondary – The Previous Secondary command causes the selected seismic bitmap 
subview to step backward one unit in accordance with the header field set as the secondary sort key 
under the File tab of the Seismic Display dialog. 
 
Next Tertiary – The Next Tertiary command causes the selected seismic bitmap subview to step 
forward one unit in accordance with the header field set as the tertiary sort key under the File tab of 
the Seismic Display dialog. 
 
Previous Tertiary – The Previous Tertiary command causes the selected seismic bitmap subview 
to step backward one unit in accordance with the header field set as the tertiary sort key under the 
File tab of the Seismic Display dialog. 
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Step Up – The Step Up command causes the selected seismic bitmap subview to step upward one 
sample interval as defined in the Vertical Axis Definition menu under the Vert Axis tab of the 
Seismic Display dialog. 
 
Step Down – The Step Down command causes the selected seismic bitmap subview to step 
downward one sample interval as defined in the Vertical Axis Definition menu under the Vert Axis 
tab of the Seismic Display dialog. 
 
 
 
 
Reset Scroll – The Reset Scroll command shifts the contents of the view so that the first trace of 
the plot range is at the left edge of the view, and the first sample is at the top.  
 
Animate 
 
 Stop – The Stop animation command stops the animation at the current display. 
 

Forward – The Forward animation command begins the animation in the forward 
horizontal direction as specified by the sort keys in the Seismic Display dialog. 

 
Reverse – The Reverse animation command begins the animation in the reverse horizontal 
direction as specified by the sort keys in the Seismic Display dialog. 

 
Up – The Up animation command begins the animation in the upward vertical direction (an 
increasing time/depth value). 

 
Down – The Down animation command begins the animation in the downward vertical 
direction (a decreasing time/depth value). 
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View 

View Menu 
 
 
 
Fit to Window – The Fit to Window command resizes all subviews on the canvas at their current 
vertical and horizontal scales so that they will fit within the visible frame of the SeisViewer 
window. If the full size of the subview at the current vertical and horizontal scales is less than the 
size of the SeisViewer window, the Fit to Window command will simply resize the subview to full 
size.  If the full size of the subview at the current vertical and horizontal scales is greater than the 
size of the SeisViewer window, the Fit to Window command will resize the subview to fit within 
the visible frame of the SeisViewer window.  To access the remainder of the seismic bitmap you 
must scroll through the subview with the mouse button. 
 
Full View – The Full View command resizes all subviews on the canvas at their current vertical 
and horizontal scales so that each subview will display the full vertical and horizontal range of data 
specified in the respective Seismic Display dialog.  If the full size of the subview at the current 
vertical and horizontal scales is greater than the size of the SeisViewer window, use of the Full 
View command will result in the subviews being expanded beyond the visible window frame. In 
this case, use the SeisViewer window’s scroll bars to view the full extent of the canvas. 
 
Expand Views – The Expand Views commands allow you to expand a selected subview to a 
maximum dimension in the vertical direction, the horizontal direction, or both. 
 

Horizontally –Expand Views Horizontally expands the selected subview on the canvas at 
it’s current vertical and horizontal scale so that the subview will display the full horizontal 
range of data specified in the Seismic Display dialog. If the full horizontal size of the 
subview at the current horizontal scale is greater than the horizontal size of the SeisViewer 
window, use of the Horizontally expand views command will result in the subview being 
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expanded beyond the visible window frame. In this case, use the SeisViewer window’s 
scroll bars to view the full extent of the canvas. 

 
 Vertically – Expand Views Vertically expands the selected subview on the canvas at it’s 

current vertical and horizontal scale so that the subview will display the full vertical range 
of data specified in the Seismic Display dialog. If the full vertical size of the subview at the 
current vertical scale is greater than the vertical size of the SeisViewer window, use of the 
Vertically expand views command will result in the subview being expanded beyond the 
visible window frame. In this case, use the SeisViewer window’s scroll bars to view the full 
extent of the canvas. 

 
 Both – The Both command in the Expand Views submenu is equivalent to the Full View 

command. 
 
Compress Views – The Compress Views commands allow you to compress a selected subview to 
a minimum dimension in the vertical direction, the horizontal direction, or both. 
 
 Horizontally – Compress Views Horizontally compresses the selected subview on the 

canvas at its current vertical and horizontal scale to a minimum horizontal dimension of 20 
pixels. 

 
 Vertically  - Compress Views Vertically compresses the selected subview on the canvas at 

its current vertical and horizontal scale to a minimum vertical dimension of 20 pixels. 
 
 Both – The Both command in the Compress Views submenu compresses the selected 

subview on the canvas at it’s current vertical and horizontal scale to a minimum of 20 pixels 
in both the vertical and horizontal dimensions. 

 
Refresh View – The Refresh View commands allow you to reload the data file displayed in a 
selected subview without opening the corresponding Seismic Bitmap or Grid Display dialog. 
 
 All – The All command in the Refresh View submenu is used to reload the seismic files 

displayed in each subview on the canvas after those files have been altered by processing in 
FlowChart.   

 
 Selected – The Selected command in the Refresh View submenu is used to reload the 

seismic files displayed in each of the selected subviews on the canvas after those files have 
been altered by processing in FlowChart. 
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Visibility – The Visibility commands allow you to view or hide a selected subview on the canvas. 
 
 Show – The Show command in the Visibility submenu will make visible all hidden 

subviews that are currently selected.  If you wish to make visible a hidden subview that is 
not selected, you select and show the subview using the Layer Table. 

 
 Hide – The Hide command in the Visibility submenu will hide all visible subviews that are 

currently selected. 
 
Background – The Background commands control the background color of the selected subview.  
Background colors currently available are opaque and transparent. 

 
 Opaque – The Opaque command in the Background submenu is used to make the 

background of a seismic bitmap or grid subview opaque. 
 
 Transparent – The Transparent command in the Background submenu is used to make the 

background of a seismic bitmap or grid subview transparent. 
  
Boarder – The Boarder commands control the presence or absence of a boarder on the selected 
subview. 
 
 On – The On command in the Boarder submenu is used to place a beveled boarder on the 

edges of the subview. 
 
 Off – The Off command in the Boarder submenu is used to remove the boarder from the 

edges of the subview. 
 
 
 
 
 
Layer Order – The Layer Order commands control the layer order of the selected subview. 
 
 Shuffle Up – The Shuffle Up command in the Layer Order submenu increments the 

drawing order of the selected subview by one. For example, a subview with a layer number 
of 1 will be shuffled up to layer 2, and the subview associated with layer 2 will shuffle 
down to layer 1. 

 
 Shuffle Down – The Shuffle Down command in the Layer Order submenu decrements the 

drawing order of the selected subview by one. For example, a subview with a layer number 
of 2 will be shuffled down to layer 1, and the subview associated with layer 1 will shuffle 
up to layer 2. 
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 Bring to Top – The Bring to Top command in the Layer Order submenu moves the 
drawing order of the selected subview to the top of the layer stack. For example, a subview 
with a layer number of 1 in a stack of 6 layers will be shuffled up to layer 6, and each of the 
subviews in layers 2-6 will shuffle down to layers 1-5, respectively. 

 
 Send to Bottom – The Send to Bottom command in the Layer Order submenu moves the 

drawing order of the selected subview to the bottom of the layer stack. For example, a 
subview with a layer number of 6 in a stack of 6 layers will be shuffled down to layer 1, and 
each of the subviews in layers 1-5 will shuffle up to layers 2-6, respectively. 

 
 
 
 
Tool Bars – The Tool Bars commands open and close toolbars on the canvas.  The toolbars 
currently available are the AddView Toolbar, the Drawing Toolbar, and the Picking Toolbar. 
 
 AddView Toolbar – The AddView Toolbar command in the Tool Bars submenu places the 

Add View toolbar on the SeisViewer canvas.  The Add View toolbar contains a button 
corresponding to each of the commands located in the Add View menu. 

 
 Drawing Toolbar – The Drawing Toolbar command in the Tool Bars submenu places the 

Drawing toolbar on the SeisViewer canvas.  In addition to the Delete Point and Delete 
Object commands located under the Edit menu, the Drawing toolbar contains a button 
corresponding to each of the commands located in the Drawing menu. 

 
 Picking Toolbar – The Picking Toolbar command in the Tool Bars submenu places the 

Picking toolbar on the SeisViewer canvas. The Picking toolbar contains a button 
corresponding to each of the commands located in the Picking menu, with the exception of 
the Picking Options… command. 

 
  
 
 
Parameters … - The Parameters… command opens the Seismic Display dialog or the Grid 
Display dialog depending on the particular subview that is selected.  The Seismic Display dialog 
and the Grid Display dialog allow you to access and review all of the display parameters associated 
with a particular subview. 
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Picking 

Picking Menu 
 
 
 
Select Traces – The Select Traces command activates the Select Traces tool.  The Select Traces 
tool is used to select one or several seismic data traces and place them on the clipboard.  Once on 
the clipboard, the traces are accessible by the Vector Calculator. The Select Traces tool is also 
accessible through the Picking toolbar. 
 
Select Area – The Select Area command activates the Select Area tool.  The Select Area tool is 
used to select a window of seismic data and place it on the clipboard.  Once on the clipboard, the 
data window is accessible by the Vector Calculator.  The Select Area tool is also accessible through 
the Picking toolbar. 
 
Invert Traces – The Invert Traces command activates the Invert Traces tool.  The Invert Traces 
tool is used to interactively reverse the polarity of seismic data on a trace-to-trace basis.  The Invert 
Traces tool is also accessible through the Picking toolbar. 
 
Scale Traces – The Scale Traces command activates the Scale Traces tool.  The Scale Traces tool 
is used to interactively scale seismic data on a trace-to-trace basis. The Scale Traces tool is also 
accessible through the Picking toolbar. 
 
Pick Traces – The Pick Traces command activates the Pick Traces tool.  The Pick Traces tool is 
used to interactively pick event times for a variety of applications, including first-break picking, 
horizon picking, and mute picking. The Pick Traces tool is also accessible through the Picking 
toolbar. 
 
Kill Traces – The Kill Traces command is used to activate the Kill Traces tool.  The Kill Traces 
tool is used to interactively kill seismic data on a trace-to-trace basis. The Trace Flag header field 
for killed traces will be set to <2>, indicating that seismic trace is not to be processed. The Kill 
Traces tool is also accessible through the Picking toolbar. 
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Unkill Traces – The Unkill Traces command is used to activate the Unkill Traces tool.  The Unkill 
Traces tool is used to interactively undo the action of the Kill Traces tool.  The Trace Flag header 
field for unkilled traces will be restored to <0>, indicating that seismic trace is to be processed.  
The Unkill Traces tool is also accessible through the Picking toolbar. 
 
 
Pick Options … - The Pick Options command opens the Pick Options dialog.  The Pick Options 
dialog controls the criteria used to automatically pick seismic events. 
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Drawing 

Drawing Menu 
 
 
 
Bitmap – The Bitmap command activates the Bitmap tool. The Bitmap tool allows you to move 
your cursor anywhere inside the current Drawing Image or Side Label subview and scroll out a 
window that will contain the bitmap image you wish to display. As soon as you release the mouse 
button, the Bitmap Object dialog will appear.  Click on the Open … button in the Bitmap Object 
dialog to select the desired bitmap file.  The Bitmap tool is also accessible through the Drawing 
toolbar. 
 
Fixed Arrow - The Fixed Arrow tools allow you to place an up/down or left/right arrow in the 
current Drawing Image or Side Label subview. 

 
Points Up – The Points Up command in the Fixed Arrow submenu activates the Fixed 
Arrow tool in the points up mode.  In the Points Up mode, the Fixed Arrow tool will place 
an upward pointing arrow in the subview with the arrowhead drawn at the mouse position. 
The Points Up tool is also accessible through the Picking toolbar. 

   
 Points Down - The Points Down command in the Fixed Arrow submenu activates the Fixed 

Arrow tool in the points down mode.  In the Points Down mode, the Fixed Arrow tool will 
place a downward pointing arrow in the subview with the arrowhead drawn at the mouse 
position. 

   
 Points Left - The Points Left command in the Fixed Arrow submenu activates the Fixed 

Arrow tool in the points left mode.  In the Points Left mode, the Fixed Arrow tool will place 
a leftward pointing arrow in the subview with the arrowhead drawn at the mouse position. 

 
 Points Right - The Points Right command in the Fixed Arrow submenu activates the Fixed 

Arrow tool in the points right mode.  In the Points Right mode, the Fixed Arrow tool will 
place a rightward pointing arrow in the subview with the arrowhead drawn at the mouse 
position. 
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Random Arrow – The Random Arrow command activates the Randomly-Oriented Arrow tool.  
The Randomly-Oriented Arrow tool allows you to place a randomly oriented arrow in the current 
Drawing Image or Side Label subview.  The randomly oriented arrow is positioned with two clicks 
of the mouse.  The first mouse click positions the arrow’s head and the second mouse click 
positions the arrow’s tail.  The Randomly Oriented Arrow tool is also accessible through the 
Picking toolbar. 

 
 
 Multi-Line Text – The Multi-Line Text command activates the Multi-Line Text tool.  Once 

activated, the Multi-Line Text tool allows you to place your cursor anywhere inside the current 
Drawing Image or Side Label subview and scroll out a window that may contain one or several 
lines of text.  Once the text window has been created simply type in the desired text.  Double-
clicking in the multi-line text window opens the Multi-Line Text dialog, which controls the text 
object background, the text object boarder, and the font type, style and size. The Multi-Line Text 
tool is also accessible through the Picking toolbar. 

  
 Polygon  - The Polygon command activates the Polygon tool. The Polygon tool allows you to 

construct a polygon in the current Drawing Image or Side Label subview. Once the Polygon tool is 
activated a single click of the mouse in the current Drawing Image or Side Label subview will 
begin construction of the polygon.  Subsequent points in the polygon are created by additional 
clicks of the mouse.  A double click of the mouse will complete the polygon.  The Polygon tool is 
also accessible through the Picking toolbar. 
 

 Polyline – The Polyline command activates the Polyline tool. The Polyline tool allows you to 
construct a polyline in the current Drawing Image or Side Label subview.   Once the Polyline tool 
is activated a single click of the mouse in the current Drawing Image or Side Label subview will 
begin construction of the polyline.  Subsequent points in the polyline are created by additional 
clicks of the mouse.  A double click of the mouse will complete a polyline. The Polyline tool is also 
accessible through the Picking toolbar. 
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Window 
 

Window Menu 
 
 
 
Layer Table – The Layer Table command opens the Layer Table.  The Layer Table provides 
control of all subview-related functions on the SeisViewer canvas.  The Layer Table allows you to 
(1) access and control each of the individual subview parameter dialogs; (2) to access and control 
the spatial relationship between individual subviews, and (3) to establish links between individual 
subviews so that they will act separately or in unison. 

 
 Spreadsheet – The Spreadsheet command opens the spreadsheet corresponding to a selected 

subview.  The spreadsheet may correspond to any of the pick formats listed under the File tab of 
the Seismic Display dialog. 
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Help 

Help menu 
 
 About …  – The About … command lists the SeisViewer version number. 
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SeisViewer Displays 
 
There are two basic display types in SeisViewer: Seismic Bitmap displays and Grid displays.  This 
chapter describes each of the Seismic Bitmap and Grid display types that are available in the 
current version of SeisViewer. 
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Seismic Bitmap Displays 
 

The Seismic Bitmap subview can display a variety of data formats, including the SPW internal 
format, several SEGY formats, and a headerless data format.  However, the SeisViewer 
architecture is optimized for the display and analysis of SPW formatted data. 
 
SPW format is the data type output by any Flowchart job to a Seismic Data file.  These may include 
standard seismic data files (i.e. shot gathers, CMP gathers, stack sections, etc…), as well as 
autocorrelations, amplitude spectra, F-K spectra, and velocity cubes.   SEGY format is a common 
archive format for seismic data.  A headerless data format describes any data that consist purely of 
sample values without trace header information. 
 
Seismic Bitmaps are displayed in SeisViewer by selecting the Add Seismic Bitmap icon from the 
Add View Toolbar and scrolling out a subview drawing area.  Once the subview window has been 
created a Seismic Display dialog will appear that will require the user to provide information 
concerning the File format and the Input file name.  If the input file is used to create a pick file, the 
user will also be require to provide information concerning the pick file format and the pick file 
name. 
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SPW Data 
 
To display SPW formatted data in a Seismic Bitmap subview display, activate the Add Seismic 
Bitmap tool.  The Add Seismic Bitmap tool is activated by clicking on the Add Seismic Bitmap 
button in the Add View Toolbar.  Alternatively, the Add Seismic Bitmap tool may be activated by 
selecting Seismic Bitmap under the Add View menu.  

The Add View Toolbar 
 
Once the Add Seismic Bitmap tool is activated, move your cursor anywhere on the open canvas, 
hold down the left mouse button, and scroll out a window that will contain the seismic data you 
wish to display.  As soon as you release the mouse button, the Seismic Display dialog will appear 
showing the menu that is located under the File tab. 

 
 

Scrolling out a subview on the SeisViewer canvas. 
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Seismic Display dialog 
 
The Seismic Display dialog allows you to (1) select the format of the data files you wish to display; 
(2) select the name of the data files you wish to display; and (3) customize the display parameters 
of the data file.  To display SPW formatted data, scroll through the drop down menu located to the 
right of the words File format and select SPW Format.  To select the name of the SPW file, click 
on the Seismic… button near the upper left-hand corner of the Seismic Display dialog.  The Open 
Data Set dialog will appear.  Use the Open Data Set dialog to browse through the directory 
structure and select the SPW file you wish to display.  The name of this file will appear to the right 
of the Seismic… button after it has been selected.  If you attempt to select a foreign file format (e.g. 
SEGY) with the File Format selection set to SPW, the following error message will appear: 

Incorrect format error message 
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Set the File format to SPW and select the appropriate SPW formatted data file. 
 
The selected seismic file may have been written to disk in a variety of sort orders.  To set the sort 
order for displaying the seismic data, configure the Primary, Secondary, and Tertiary Sort keys in 
the lower half of the Seismic Display dialog.  Each of these sort keys is set by scrolling through the 
drop down menu located to the right of the particular sort key.  The following examples will 
illustrate the display of field files, common receiver gathers, and common midpoint gathers from a 
single SPW data file with fully updated trace headers.    
 
The sort keys in the figure above are set to Primary: Field File Number; Tertiary: Channel. This is 
standard sort order for the display of a field file.  To display the field file, simply click on the OK 
button in the upper left corner of the Seismic Display dialog.  Use the scroll keys to step through 
the field files. 
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Display of a SPW formatted field file without annotation. 
 
 
Use the Add Horizontal Axis and Add Vertical Axis tools to annotate the display with field file 
number, channel number, and two-way travel time. 

 
 

Annotated field file display. 



 75 

To display the same data file as a series of common-receiver gathers, double-click on the seismic 
bitmap subview to open the Seismic Display dialog.  Set the sort keys to Primary: Receiver 
Location; Tertiary: Source-Receiver Offset. This is a standard sort order for the display of 
common-receiver gathers.  To display the common-receiver gather, simply click on the OK button 
in the upper left corner of the Seismic Display dialog.  The horizontal annotation will be updated 
accordingly.  Use the scroll keys to step through the common-receiver gathers. 
 

To display a common-receiver gather, set the Sort keys to Primary: Receiver 
Location; Tertiary: Source-Receiver Offset. 

 

Annotated common-receiver gather. 
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To display the same data file as a series of common-midpoint gathers, double-click on the seismic 
bitmap subview to open the Seismic Display dialog.  Set the sort keys to Primary: CMP Location; 
Tertiary: Source-Receiver Offset. This is standard sort order for the display of a common-midpoint 
gather.  To display the common-midpoint gather, simply click on the OK button in the upper left 
corner of the Seismic Display dialog.  The horizontal annotation will be updated accordingly.  Use 
the scroll keys to step through the common-midpoint gathers. 

To display a common-midpoint gather, set the Sort keys to Primary: CMP Location; 
Tertiary: Source-Receiver Offset. 

 

Annotated common-midpoint gather. 
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SEGY Data 
To display SEGY formatted data in a Seismic Bitmap subview display, activate the Add Seismic 
Bitmap tool.  The Add Seismic Bitmap tool is activated by clicking on the Add Seismic Bitmap 
button in the Add View Toolbar.  Alternatively, the Add Seismic Bitmap tool may be activated by 
selecting Seismic Bitmap under the Add View menu.  
 

 
Once the Add Seismic Bitmap tool is activated, move your cursor anywhere on the open canvas, 
hold down the left mouse button, and scroll out a window that will contain the seismic data you 
wish to display.  As soon as you release the mouse button, the Seismic Display dialog will appear 
showing the menu that is located under the File tab. 
 

Scrolling out a subview on the SeisViewer canvas. 
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Seismic Display dialog 
 
The Seismic Display dialog allows you to (1) select the format of the data files you wish to display; 
(2) select the name of the data files you wish to display; and (3) customize the display parameters 
of the data file.  To display SEGY formatted data, scroll through the drop down menu located to the 
right of the words File format and select SEGY Default Format.  To select the name of the SEGY 
file, click on the Seismic… button near the upper left-hand corner of the Seismic Display dialog.  
The Open Data Set dialog will appear.  Use the Open Data Set dialog to browse through the 
directory structure and select the SEGY file you wish to display.  The name of this file will appear 
to the right of the Seismic… button after it has been selected.  If you attempt to select a non-SEGY 
file format (e.g. SPW) with the File Format selection set to SEGY Default Format, the following 
error message will appear: 
 

 Incorrect format error message 
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Set the File format to SEGY Default Format and select the appropriate SEGY formatted data file. 
 
The selected seismic file may have been written to disk in a variety of sort orders.  To set the sort 
order for displaying the seismic data, configure the Primary, Secondary, and Tertiary Sort keys in 
the lower half of the Seismic Display dialog.  Each of these sort keys is set by scrolling through the 
drop down menu located to the right of the particular sort key.  The following examples will  
illustrate the display of field files, common receiver gathers, and common midpoint gathers from a 
data file with fully updated trace headers.    
 
The sort keys in the figure above are set to Primary: Source record Number; Tertiary: Offset. This 
is a standard sort order for the display of field files in SEGY format.  To display the field file, 
simply click on the OK button in the upper left corner of the Seismic Display dialog.  Use the scroll 
keys to step through the field files. 
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SEGY field file display without annotation. 
 
 
Use the Add Horizontal Axis and Add Vertical Axis tools to annotate the display with field file 
number, channel number, and two-way travel time. 

 
 

Annotated SEGY field file display. 
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To display the same data file as a series of common-receiver gathers, double-click on the seismic 
bitmap subview to open the Seismic Display dialog.  Set the sort keys to Primary: Receiver Group 
number; Tertiary: Offset. This is a standard sort order for the display of common-receiver gathers 
in SEGY format.  To display the common-receiver gather, simply click on the OK button in the 
upper left corner of the Seismic Display dialog.  The horizontal annotation will be updated 
accordingly.  Use the scroll keys to step through the common-receiver gathers. 
 

To display a common-receiver gather, set the Sort keys to Primary: Receiver group 
number; Tertiary: Offset. 

 

Annotated common-receiver gather in SEGY format. 
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To display the same data file as a series of common-midpoint gathers, double-click on the seismic 
bitmap subview to open the Seismic Display dialog.  Set the sort keys to Primary: CDP number; 
Tertiary: Offset. This is a standard sort order for the display of common-midpoint gathers in SEGY 
format.  To display the common-midpoint gather, simply click on the OK button in the upper left 
corner of the Seismic Display dialog.  The horizontal annotation will be updated accordingly. Use 
the scroll keys to step through the common-midpoint gathers. 
 

To display a common-midpoint gather, set the Sort keys to Primary: CMP number; Tertiary: Offset. 
 

Annotated common-midpoint gather in SEGY format. 
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Grid Displays 
 

 
The Grid Display subview can display two types of grids: (1) SPW Grids that are generated in 
Flowchart as 'Image Data...' files, and (2) grids that are generated in SeisViewer from seismic data 
that has been output in a Flowchart processing flow.  Currently supported SPW Grid types are: 
 
  3-D CMP Fold Image 
  F-T Frequency Slice Image 
  F-T Time Slice Image 
 
Grid types generated in SeisViewer from SPW formatted seismic data include: 
 
  Eta Spectra 

F-K Spectra 
  Gamma Semblance 
  HOVA (Horizon Velocity Analysis) 
  Instantaneous Amplitude 
  Instantaneous Frequency 
  Instantaneous Phase 
  Time Slices 
  Velocity (Velocity Field Displays) 
  Velocity Semblance 
  Velocity Semblance Delta-T 
 
 
Grids are displayed in SeisViewer by selecting the Add Grid icon from the Add View Toolbar and 
scrolling out a subview drawing area.  Once the subview window has been created, a Grid Display 
dialog will appear that will require the user to provide information concerning the File format, the 
Display type, and the Input file name.  With the exception of Time Slice displays, each of the grids 
generated in SeisViewer from SPW formatted seismic data will require parameter input via the 
Options button located on the Grid Display dialog. 
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3D Fold Displays 
 

SeisViewer canvas illustrating bin fold extracted from SPS survey files (top) and seismic trace 
headers (bottom). 

 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Generate a CMP Fold Image map in FlowChart using a flow similar to the example on the 

next page.  CMP Fold Image maps may be extracted from either SPS survey files using 
the 3-D CMP Fold – Geometry step, or from the seismic trace headers using the 3-D CMP 
Fold – Data step. 
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Step 1: Flowchart job to generate CMP Fold Image maps from both SPS survey files 
and from the seismic trace header. 

 

 
Step 2: Open a Seismic Grid subview, set the File format to SPW Grid, and set the Display type 

format to Fold.  Select the appropriate CMP Fold Image file using the Source… button.  
Adjust the horizontal and vertical scales as necessary.  Set the color scale under the Grid 
Style tab and add reference lines if desired.  Click OK in the upper left corner of the Grid 
Display dialog to display the fold map. 

 
 

Step 2: Select file format, the display type, and the CMP Fold Image file. 
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Eta Semblance 
 

 SeisViewer canvas displaying an Eta semblance gather. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1: Open a Grid subview.  Set the File format to SPW Seismic and the Display type format to 

Eta Semblance.  Use the Source… button to select the file of uncorrected CMP gathers 
that will be used in the Eta semblance analysis.  
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Step 1: Select File format, the Display type, and the CMP gathers for Eta semblance analysis. 
 

 
Step 2: Open the Eta Semblance dialog by clicking on the Options… button located to the right 

of the Display type drop down menu in the Grid Display dialog.  The Eta Semblance 
dialog is used to set parameters for the semblance analysis and select the corresponding P-
wave stacking velocity function.  The P-wave velocity file is selected with the Browse 
button.  It is not necessary that the Eta functions be picked at the same locations as the 
functions in the P-wave stacking velocity file.  Once the parameters have been specified, 
click on the OK button at the bottom of the Eta Semblance dialog. 

 

Step 2: Set parameters in the Eta Semblance dialog. 
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Step 3:  Select Eta Semblance from the pick file formats drop down menu in the Grid Display 
dialog, and select/create the file that will contain the time-eta semblance picks defined by 
the interactive picking session. 

 

Step 3: Set the pick File format, and select/create velocity pick file. 
 
 
Step 4: Click OK in the upper left corner of the Grid Display dialog to generate the Eta-

semblance gathers.  If you want to change either the horizontal or the vertical scale of the 
resulting semblance panel, simply adjust the relevant parameters in the Grid Scale menu. 

 
Step 5: Pick the Eta-semblance spectra to define an Eta function. To make a semblance pick, use 

the left mouse button and select points on the spectra where you would like the Eta 
function.  To edit an Eta pick, click on the pick with the left mouse button, hold down the 
button, and drag the Eta pick to the desired position.  To end the edit, double click with 
the left mouse button.  To delete an Eta pick, click once on the pick to select it, and then 
delete the pick with either the Delete Pick command located under the Edit menu, or 
simply hit Delete on the Keyboard.  To save the Eta file, select Save Canvas from the File 
menu. 
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Step 5: Make eta-time picks with the left mouse button. 
 

Step 5: To complete the function, double-click with the left mouse button. 
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F-K Spectra 
 
 

 SeisViewer canvas displaying an F-K spectrum. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1: Open a Grid subview, set the File format to SPW Seismic and the Display type format to 

FK Spectrum.  Use the Source… button to select the SPW file that you wish to analyze in 
the FK domain.  
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Step 1: Select the File format, the Display type, and select the file for analysis. 
 

 
Step 2: Open the F-K Spectrum dialog by clicking on the Options… button in the Grid Display 

dialog.  The F-K Spectrum dialog is used to set parameters used to generate the F-K 
spectra.  Once the parameters have been specified, click on the OK button at the bottom of 
the dialog. 

 

Step 2: Set parameters in the F-K Spectrum dialog. 
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 Step 3: Click OK in the upper left corner of the Grid Display dialog to generate the F-K spectra. 
 
 

Step3:  Example of an F-K spectrum. 
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F-T Frequency Slice Displays 
 

SeisViewer canvas illustrating a 48 Hz F-T Frequency slice (right) generated from a stack section (left). 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Generate an F-T Frequency Slice image file in FlowChart using a flow similar to the 

example illustrated on the following page.  F-T frequency slices are created with the F-T 
Frequency Slice step and output as an F-T Frequency Slice Image file.   
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Step 1: Example flowchart to generate an F-T Frequency Slice. 

 
 

Step 2: Open a Seismic Grid subview, set the file format to SPW Grid and the Display type 
format to F-T Frequency.  Select the appropriate F-T Frequency Slice Image file using the 
Source… button.  Adjust the horizontal and vertical scales as necessary.  Set the color 
scale under the Grid Style tab and add reference lines if desired.  Click OK in the upper 
left corner of the Grid Display dialog to display the F-T Frequency Slice. 

 

Step 2: Select the F-T Frequency Slice Image file, the File format, and the Display type. 
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Step 3: Add vertical and horizontal annotations and a color bar if desired. 
 

 

 

Example display of an F-T Frequency Slice Image file. 
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F-T Time Slice Displays 
 

SeisViewer canvas illustrating a 60 Hz F-T Time slice (right) generated from a stack section (left). 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Generate an F-T Time Slice image file in FlowChart using a flow similar to the example 

illustrated on the following page.  F-T Time slices are created with the F-T Time Slice 
step and output as an F-T Time Slice Image file. 
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Step 1: Example flowchart to generate an F-T Time Slice. 

 
Step 2: Open a Seismic Grid subview, set the file format to SPW Grid, and set the Display type 

format to F-T Time.  Select the appropriate F-T Time Slice Image file using the Source… 
button.  Adjust the horizontal and vertical scales as necessary.  Set the color scale under 
the Grid Style tab and add reference lines if desired.  Click OK in the upper left corner of 
the Grid Display dialog to display the fold map. 

 

Step 2: Select the F-T Time Slice Image file, the File format, and the Display type. 
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 Step 3: Add vertical and horizontal annotations and a color bar if desired. 
 

Example display of an F-T Time Slice Image file. 
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Gamma Semblance 
 

 SeisViewer canvas displaying a Gamma semblance gather. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1: Open a Grid subview.  Set the File format to SPW Seismic and the Display type format to 

Gamma Semblance.  Use the Source… button to select the file of uncorrected CCP 
gathers that will be used in the Gamma semblance analysis.  
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Step 1: Select File format, the Display type, and the CMP gathers for Gamma semblance analysis. 

 

 

Step 2: Open the Gamma Semblance dialog by clicking on the Options… button located to the 
right of the Display type drop down menu in the Grid Display dialog.  The Gamma 
Semblance dialog is used to set parameters for the semblance analysis and select the 
corresponding P-wave stacking velocity function.  The P-wave velocity file is selected 
with the Browse button.  It is not necessary that the Gamma functions be picked at the 
same locations as the functions in the P-wave stacking velocity file.  Once the parameters 
have been specified, click on the OK button at the bottom of the Gamma Semblance 
dialog. 

 

Step 2: Set parameters in the Gamma Semblance dialog. 
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Step 3:  Select Gamma Semblance from the pick file formats drop down menu in the Grid 
Display dialog, and select/create the file that will contain the time-gamma semblance 
picks defined by the interactive picking session. 

 

Step 3: Set the pick File format, and select/create velocity pick file. 
 
 
Step 4: Click OK in the upper left corner of the Grid Display dialog to generate the gamma-

semblance gathers.  If you want to change either the horizontal or the vertical scale of the 
resulting semblance panel, simply adjust the relevant parameters in the Grid Scale menu. 

 
Step 5: Pick the gamma-semblance spectra to define a gamma function. To make a semblance 

pick, use the left mouse button and select points on the spectra where you would like the 
gamma function.  To edit an gamma pick, click on the pick with the left mouse button, 
hold down the button, and drag the gamma pick to the desired position.  To end the edit, 
double click with the left mouse button.  To delete an gamma pick, click once on the pick 
to select it, and then delete the pick with either the Delete Pick command located under 
the Edit menu, or simply hit Delete on the Keyboard.  To save the gamma file, select Save 
Canvas from the File menu. 
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Step 5: Make gamma-time picks with the left mouse button. 
 

Step 5: To complete the function, double-click with the left mouse button.
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Horizon Velocity Analysis 
 

SeisViewer canvas illustrating a horizon-consistent semblance gather used for interactive horizon 
consistent velocity analysis. 

 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Grid subview, set the File format to SPW Seismic and the Display type format to 

HOVA (horizon velocity analysis).  Use the Source… button to select the file of 
uncorrected CMP gathers that will be used in the horizon velocity analysis. 
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Step 1: Select file format, the display type, and the CMP gathers for horizon velocity analysis. 
 

 
Step 2: Open the Horizon Velocity Analysis dialog by clicking on the Options… button in the 

Grid Display dialog.  The Horizon Velocity Analysis dialog is used to (1) set parameters 
for the horizon velocity analysis; (2) select the horizon file that will control the analysis; 
(3) create/choose the velocity file that will contain the time-velocity picks defined by the 
interactive picking session. Once the files and the parameters have been specified, click 
on the OK button in the lower left corner of the Horizon Velocity Display dialog.  

 

Step 2: Set parameters in the Horizon Velocity Analysis dialog. 
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Step 3:  Select HOVA Velocity from the pick file formats drop down menu in the Grid Display 
dialog, and select/create the file that will contain the horizon-velocity picks in an Event 
Time Pick format defined by the interactive picking session.  This file name should be 
different from that of the velocity file defined in the Horizon Velocity Analysis dialog in 
Step 2. 
 

Step 3: Set the pick file format to Hova Velocity and select/create a file using the Picks… button. 
 
 

Step 4: Click OK in the upper left corner of the Grid Display dialog.  The horizon consistent 
semblance spectra used for the horizon velocity analysis will be generated. Annotate with 
the spectra horizontally and vertically as desired. 

 

Step 5: Pick the horizon-consistent semblance spectra to define a velocity function. To make a 
semblance pick, use the left mouse button and select points on the spectra where you 
would like the velocity function.  To edit a velocity pick, click on the pick with the left 
mouse button, hold down the button, and drag the velocity pick to the desired position.  
To end the edit, double click with the left mouse button.  To delete a velocity pick, click 
once on the pick to select it, and then delete the pick with either the Delete Pick command 
located under the Edit menu, or simply hit Delete on the Keyboard.  To save the velocity 
file, select Save Canvas from the File menu. 
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Step 5: A picked horizon-consistent semblance gather.  
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Instantaneous Amplitude 
 

 SeisViewer canvas displaying a time section and the corresponding instantaneous amplitude attributes. 
 
 

To create an instantaneous amplitude attribute section in SeisViewer similar to that in the figure 
above, perform the following steps: 
 
Step 1:  Generate a 2D/3D stack volume in FlowChart.    

 
Step 2: Open a Grid subview.  Set the Source file format to SPW Seismic and the Display type to 

Instantaneous Amplitude.  Use the Source… button to select the seismic file generated 
in FlowChart from which you wish to compute the instantaneous amplitude attribute.  
Adjust the horizontal, vertical, and scaling parameters as desired.  Annotate with a vertical 
and horizontal annotations, and a color bar if desired. 
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Step 2: Select the stack volume, the File format, and the Display type. 
 

Instantaneous amplitude section. 
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Instantaneous Frequency 
 

 SeisViewer canvas displaying a time section and the corresponding instantaneous frequency attributes. 
 
 

To create an instantaneous frequency attribute section in SeisViewer similar to that in the figure 
above, perform the following steps: 
 
Step 1:  Generate a 2D/3D stack volume in FlowChart.    

 
Step 2: Open a Grid subview.  Set the Source file format to SPW Seismic and the Display type to 

Instantaneous Frequency.  Use the Source… button to select the seismic file generated 
in FlowChart from which you wish to compute the instantaneous frequency attribute.  
Adjust the horizontal, vertical, and scaling parameters as desired.  Annotate with a vertical 
and horizontal annotations, and a color bar if desired. 
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Step 2: Select the stack volume, the File format, and the Display type. 
 
 

An instantaneous frequency section. 
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Instantaneous Phase 
 

 SeisViewer canvas displaying a time section and the corresponding instantaneous frequency attributes. 
 
 

To create an instantaneous frequency phase section in SeisViewer similar to that in the figure 
above, perform the following steps: 
 
Step 1:  Generate a 2D/3D stack volume in FlowChart.    

 
Step 2: Open a Grid subview.  Set the Source file format to SPW Seismic and the Display type to 

Instantaneous Phase.  Use the Source… button to select the seismic file generated in 
FlowChart from which you wish to compute the instantaneous phase attribute.  Adjust the 
horizontal, vertical, and scaling parameters as desired.  Annotate with a vertical and 
horizontal annotations, and a color bar if desired. 
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Step 2: Select the stack volume, the File format, and the Display type. 
 
 

An instantaneous phase section. 
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Time Slices 
 

 SeisViewer canvas displaying a time slice at 1900ms through a 3D stacked volume. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Generate a 3D stack volume in FlowChart.    
 

Step 2: Open a Grid subview.  Set the Source file format to SPW Seismic and the Display type to 
Time Slice.  Use the Source… button to select the 3D stack volume generated in 
FlowChart.  Adjust the horizontal, vertical, and scaling parameters as desired.  Annotate 
with a vertical and horizontal annotations, and a color bar if desired. The start time of the 
first time slice and the step size are set in the Grid Scale submenu of the Grid Display 
dialog.  Use the scroll keys to step up or down in time through the stack volume.  
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Step 2: Select the 3D stack volume, the File format, and the Display type. 
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Velocity Field Displays 
 

SeisViewer canvas displaying an interactively picked stacking velocity field. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Perform stacking velocity analysis by any of the means described in the chapter on 

Velocity Picking.    
 

Step 2: Open a Grid subview. Set the Source file format to SPW Seismic and the Display type to 
Velocity.  Use the Source… button to select a seismic stacked section of the line on 
which you picked velocities.  The trace header values in this stacked section are used as a 
reference for the velocity field.  Adjust the horizontal and vertical scales as necessary.  Set 
the color scale under the Grid Style tab.  Add reference lines if desired. 
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Step 2. Select the stacked section, set the File format to SPW Seismic, the Display type to Velocity. 

 
 
Step 3: Click on the Options… button to open the Velocity Model Options dialog.  Use the 

Browse button in the Velocity Model Options dialog to select the velocity file you wish to 
display.  To display the velocity field contained in a velocity file, check Display velocity 
pick locations. To display the interval velocity field corresponding to a selected stacking 
velocity field, check Apply Dix eqn for interval velocities.  Click OK in the Velocity 
Model Options dialog, followed by OK in the Grid Display dialog. 

 

Step 3.  The Velocity Model Options dialog. 
 
Step 4: Add vertical timing lines, horizontal locations, and a color bar. 
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Step 4.  The velocity field display. 
 
 
 

Step 5: The stacked section selected in Step 2 may be overlain on the velocity field selected in 
Step 3 in order to correlate stacking velocity with the spatial position of seismic events.  
To overlay the stacked section on the velocity field, activate the Seismic Bitmap tool and 
scroll out a Seismic Bitmap subview window that is coincident with the existing velocity 
field window.  Set the Source file format to SPW Seismic and use the Source… button to 
select the stacked section selected in Step 2. 
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Step 5. Scroll out a Seismic Bitmap subview window that is coincident with the existing velocity field window.  
Set the file format to SPW Seismic and use the Source… button to select the stacked section selected in Step 2. 

 
Step 6: Make sure that the vertical and horizontal scales of the Seismic Bitmap file are consistent 

with those of the Seismic Grid file.  Click OK in the upper left corner of the Seismic 
Display dialog. 

Step 6.  The selected seismic section will now overlay the velocity field. 
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Step 7: Use the Layer Table to synchronize the vertical and horizontal scroll groups of the Grid 
display and the Seismic Bitmap display. 

 

Step 7: Use the Layer Table to synchronize the vertical and horizontal scroll groups of the 
Grid display and the Seismic Bitmap display. 

 
 
Step 8: Select the layer corresponding to the stacked section in the Seismic Bitmap overlay.  In 

the current example, this is layer 6.  The stacked section used as a reference for the 
velocity field display is in layer 5.  With the layer 6 highlighted, use the mouse to select 
Transparent Background from the View menu.  This will allow the underlying velocity 
field to visible. 

 

Step 8: Click on the layer corresponding to the Seismic Bitmap subview and make it’s 
background transparent. 
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Step 8: The velocity field overlain on the corresponding stacked section. 
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Velocity Semblance 
 

 SeisViewer canvas displaying a velocity semblance gather. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1: Open a Grid subview, set the File format to SPW Seismic and the Display type format to 

Velocity Semblance.  Use the Source… button to select the file of uncorrected CMP 
gathers that will be used in the semblance analysis.  
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Step 1: Select File format, the Display type, and the CMP gathers for semblance analysis. 
 

 
Step 2: Open the Velocity Semblance dialog by clicking on the Options… button in the Grid 

Display dialog.  The Velocity Semblance dialog is used to set parameters for the 
semblance analysis.  Once the parameters have been specified, click on the OK button at 
the bottom of the Velocity Semblance dialog. 

 

Step 2: Set parameters in the Velocity Semblance dialog. 
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Step 3:  Select Velocity Semblance from the pick file formats drop down menu in the Grid 
Display dialog, and select/create the file that will contain the time-velocity semblance 
picks defined by the interactive picking session. 

 

Step 3: Set the pick File format, and select/create velocity pick file. 
 
 
Step 4: Click OK in the upper left corner of the Grid Display dialog to generate the semblance 

gathers. 
 
Step 5: Pick the velocity semblance spectra to define a velocity function. To make a semblance 

pick, use the left mouse button and select points on the spectra where you would like the 
velocity function.  To edit a velocity pick, click on the pick with the left mouse button, 
hold down the button, and drag the velocity pick to the desired position.  To end the edit, 
double click with the left mouse button.  To delete a velocity pick, click once on the pick 
to select it, and then delete the pick with either the Delete Pick command located under 
the Edit menu, or simply hit Delete on the Keyboard.  To save the velocity file, select 
Save Canvas from the File menu. 
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Step 5: Make velocity-time picks with the left mouse button. 
 

Step 5: To complete the function, double-click with the left mouse button. 
 
 



 125 

Velocity Semblance Delta-T 
  

 SeisViewer canvas displaying a delta-T velocity semblance gather. 
 
 

To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1: Open a Grid subview, set the File format to SPW Seismic and the Display type format to 

Velocity Semblance Delta T.  Use the Source… button to select the file of uncorrected 
CMP gathers that will be used in the delta-T semblance analysis.   
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Step 1: Select File format, the Display type, and the CMP gathers for delta- T semblance analysis. 

 

 
Step 2: Open the Velocity Semblance Delta T dialog by clicking on the Options… button in the 

Grid Display dialog.  The Velocity Semblance Delta T dialog is used to set parameters for 
the delta T semblance analysis.  Use the Browse button to select a reference velocity file 
created by a previous velocity analysis of the selected data.  Once the parameters have 
been specified, click on the OK button at the bottom of the Velocity Semblance dialog. 

 

Step 2: Set parameters in the Velocity Semblance DeltaT dialog. 
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Step 3:  Select Velocity Semblance from the pick file formats drop down menu in the Grid 
Display dialog, and select/create the file that will contain the time-velocity delta-T 
semblance picks defined by the interactive picking session. 

 

Step 3: Set the pick File format, and select/create velocity pick file. 
 
 
Step 4: Click OK in the upper left corner of the Grid Display dialog to generate the delta-T 

semblance gathers. 
 
Step 5: Pick the delta-T velocity semblance spectra to define a velocity function. To make a 

semblance pick, use the left mouse button and select points on the spectra where you 
would like the velocity function.  To edit a velocity pick, click on the pick with the left 
mouse button, hold down the button, and drag the velocity pick to the desired position.  
To end the edit, double click with the left mouse button.  To delete a velocity pick, click 
once on the pick to select it, and then delete the pick with either the Delete Pick command 
located under the Edit menu, or simply hit Delete on the Keyboard.  To save the velocity 
file, select Save Canvas from the File menu. 
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Step 5.  Make velocity-time picks with the left mouse button. 
 

 

Step 5. To complete the function, double-click with the left mouse button. 
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Color Scales 
 
The SeisViewer application is supplied with six color scales.  To create a custom Color Scale 
Format (CSF) File for SeisViewer, read the following instructions, which describe how to alter the 
existing Rainbow.csf color scale format file to a color scale whose spectrum extends from blue 
through cream to red.  Colors in the color scale are represented as hexadecimal numbers. 
 
Step 1:  Open the existing Rainbow.csf file in the PGC directory (i.e. Program Files/pgc) and 

save it as another file with a name depicting the color scheme you are designing (i.e. 
Blue Cream Red 64.csf).  

 
Step 2: Change line 3 of the .csf file from Rainbow.csf to the new name of the file (i.e. Blue 

Cream Red 64.csf).   Change the line that reads “Name = Rainbow” to Name = Blue 
Cream Red 64.  

 
Step 3: Change "Dither = Yes" to "Dither = No". 
 
Step 4: Change the first color line from "Color = 0xff0000 to 0xffff00 4” to   

“Color = 0x0000ff to 0xd8d8bf  32”.  This sets up the negative half of the color 
scale. 

 
Step 5: Change the next color line from "Color = 0xffff00 to 0x00ff00 4” to   

“Color = 0xd8d8bf to 0xff000  32”.  This sets up the positive half of the color scale. 
 
Step 6: Delete or comment out the other appended color lines.  
 
Step 7: Save the file. 
 
Step 8:  To load the custom color scheme, use the Browse button located under the Plot Style 

tab of the Seismic Display dialog, or under the Grid Style display of the Grid 
Display dialog.  Once the custom .csf file has been selected it will appear in the 
color scale drop down menu.  

 
Step 9: Experiment with the colors below and design any color scheme you wish.  
 
 
Hex Color Codes: 
 
White = FFFFFF 
Red = FF0000 
Green = 00FF00 
Blue = 0000FF 
Magenta = FF00FF 
Cyan = 00FFFF 
Yellow = FFFF00 
Black = 000000 
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Aquamarine = 70DB93 
Baker's Chocolate = 5C3317 
Blue Violet = 9F5F9F 
Brass = B5A642 
Bright Gold = D9D919 
Brown = A62A2A 
Bronze = 8C7853 
Bronze II = A67D3D 
Cadet Blue = 5F9F9F 
Cool Copper = D98719 
Copper = B87333 
Coral = FF7F00 
Corn Flower Blue = 42426F 
Dark Brown = 5C4033 
Dark Green = 2F4F2F 
Dark Green Copper = 4A766E 
Dark Olive Green = 4F4F2F 
Dark Orchid = 9932CD 
Dark Purple = 871F78 
Dark Slate Blue = 6B238E 
Dark Slate Grey = 2F4F4F 
Dark Tan = 97694F 
Dark Turquoise = 7093DB 
Dark Wood = 855E42 
Dim Grey = 545454 
Dusty Rose = 856363 
Feldspar = D19275 
Firebrick = 8E2323 
Forest Green = 238E23 
Gold = CD7F32 
Goldenrod = DBDB70 
Grey = C0C0C0 
Green Copper = 527F76 
Green Yellow = 93DB70 
Hunter Green = 215E21 
Indian Red = 4E2F2F 
Khaki = 9F9F5F 
Light Blue = C0D9D9 
Light Grey = A8A8A8 
Light Steel Blue = 8F8FBD 
Light Wood = E9C2A6 
Lime Green = 32CD32 
Mandarian Orange = E47833 
Maroon = 8E236B 
Medium Aquamarine = 32CD99 
Medium Blue = 3232CD 
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Medium Forest Green = 6B8E23 
Medium Goldenrod = EAEAAE 
Medium Orchid = 9370DB 
Medium Sea Green = 426F42 
Medium Slate Blue = 7F00FF 
Medium Spring Green = 7FFF00 
Medium Turquoise = 70DBDB 
Medium Violet Red = DB7093 
Medium Wood = A68064 
Midnight Blue = 2F2F4F 
Navy Blue = 23238E 
Neon Blue = 4D4DFF 
Neon Pink = FF6EC7 
New Midnight Blue = 00009C 
New Tan = EBC79E 
Old Gold = CFB53B 
Orange = FF7F00 
Orange Red = FF2400 
Orchid = DB70DB 
Pale Green = 8FBC8F 
Pink = BC8F8F 
Plum = EAADEA 
Quartz = D9D9F3 
Rich Blue = 5959AB 
Salmon = 6F4242 
Scarlet = 8C1717 
Sea Green = 238E68 
Semi-Sweet Chocolate = 6B4226 
Sienna = 8E6B23 
Silver = E6E8FA 
Sky Blue = 3299CC 
Slate Blue = 007FFF 
Spicy Pink = FF1CAE 
Spring Green = 00FF7F 
Steel Blue = 236B8E 
Summer Sky = 38B0DE 
Tan = DB9370 
Thistle = D8BFD8 
Turquoise = ADEAEA 
Very Dark Brown = 5C4033 
Very Light Grey = CDCDCD 
Violet = 4F2F4F 
Violet Red = CC3299 
Wheat = D8D8BF 
Yellow Green = 99CC32 
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SeisViewer Processing 
 
SeisViewer allows for the application and testing of a limited number of the processing steps 
currently available in the SPW Processing library.  Each of the processing steps in the SeisViewer 
processing library permits single channel operations.  A maximum of three of these processing 
steps may be applied sequentially to any input file.  Multichannel operations such as F-K filtering, 
Shot Deconvolution, and Migration are not available. 
 
The processing steps currently available in the SeisViewer Processing library are: 

 
 

 
 

 
 

 
This chapter will illustrate SeisViewer’s processing capabilities through the interactive selection of 
predictive-deconvolution parameters.

Apply Early Mute Deconvolution Spherical Divergence Correction 
Apply Linear Moveout Derivative Time Variant Bandpass 
Apply Normal Moveout Integration Time Variant Butterworth 
Apply PP Nonhyp Moveout Median Filter Time Variant Decovolution 
Apply PS Nonhyp Moveout Phase Rotation Trace Math 
Apply Surgical Mute Remove DC Bias Windowed AGC 
Apply Tail Mute Sliding Window AGC  
Autocorrelation Spectral Whitening  
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The figure above illustrates an example of predictive-deconvolution parameter selection using the 
SeisViewer’s processing capabilities.  Trace-to-trace autocorrelations (top center) of the input 
gather (left) are used in the design of deconvolution operators.  Predictive deconvolution is applied 
to the input gather (right), and trace-to-trace autocorrelations of the deconvolved gather (bottom 
center) are used to qualify the deconvolution parameterization.  The remainder of the chapter will 
describe the procedures required to generate the above canvas.  If you have any questions regarding 
specific processing parameters, please consult the SPW Flow Chart manual. 
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To initiate any processing step or sequence of steps, we will always start with an input seismic data 
file. You may annotate the seismic display in any manner you like.  

 

Input source record with relative-amplitude scaling. 
 
The source record displayed in the figure above contains a few near-offset traces that contain high-
amplitude noise bursts that should be edited prior to deconvolution or any subsequent processing 
steps.  Noisy traces can be edited interactively in SeisViewer through the use of the Kill Traces tool 
located under the Picking menu.  To activate the Kill Traces tool, select Kill Traces from the 
Picking drop down menu. 
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Selection of the interactive Kill Trace tool under the SeisViewer Picking menu. 
 
To kill a trace, simply position the cursor over the noisy trace and single click with the left mouse 
button.  The edited trace will be plotted as a straight line and the value <2> will be placed in the 
Trace Flag trace header field indicating that the trace is not to be processed.  The Unkill Traces tool 
is available to undo the action of the Kill Traces tool.  Again, simply select the Unkill Traces tool 
from the Picking menu, position the cursor over the previously killed trace, and click once with the 
left mouse button.  The Trace Flag header field will be restored to <0>, indicating that seismic trace 
is to be processed.   
 
The Picking menu also provides a Scale tool for interactively scaling individual traces, and an 
Invert Traces tool to interactively reverse the polarity of individual traces. 
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Illustration of trace kills with the interactive Kill Traces tool. 
 
Subsequent processing of the selected shot gather will not take into account the edited traces. The 
gather is now ready for parameter testing. 
 
The spatial and temporal position of deconvolution design windows within SPW may be controlled 
by one of two means: as a linear function of offset (i.e. LMO), or as a function of an Early Mute 
card.  In the present example, we will illustrate the use of an Early Mute card to control the position 
of the design window.   
 
Double click on the seismic bitmap to open the Seismic Display dialog.  Set the pick file format to 
Early Mute and use the Picks… button to select/create the card data file that will contain the early 
mute functions defined by the interactive picking session.  To pick the early mute on the input 
gather, use the left mouse button and select points on the gather where you would like the mute 
function.  To edit a mute pick, click on the pick with the left mouse button, hold down the button, 
and drag the mute pick to the desired position.  To end the edit, double click with the left mouse 
button.  To delete a mute pick, click once on the pick to select it, and then delete the pick with 
either the Delete Pick command located under the Edit menu, or simply hit Delete on the Keyboard. 
To view the mute function, select Spreadsheet from the Windows menu on the main toolbar.  To 
save the mute file, select Save Canvas from the File menu. 
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Set the pick file format to Early Mute, and select the file that will contain the early mute function. 
    

Pick the Early Mute function that will control the start time of the deconvolution design window. 
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The first step in the design of prediction deconvolution parameters is the generation of trace-to-
trace autocorrelations.  Autocorrelations are used to design the prediction gap and the 
deconvolution operator length.  Create a second Seismic Bitmap subview and select the same 
seismic file that is displayed in the subview titled “Input Gather”.  To set the processing parameters 
that will be applied to the second Seismic Bitmap subview, click on the Process tab. 

 

Select the input gather from which to generate trace-to-trace autocorrelations. 
 

The Process menu 
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The autocorrelations will be generated from data samples that follow a time function defined in the 
Early Mute card.  Therefore, the first processing step will be to apply this mute function.  Select the 
Apply Early Mute step from the drop down menu in the Process 1 submenu.  Once the Apply Early 
Mute step has been selected, use the File… button to the right of the drop down menu to select the 
early mute file picked on the input gather.  Use the Parameters… button to the immediate right of 
the drop down to select the mute taper length and the mute taper type. 
  

First processing step: Apply Early Mute 
 

The Early Mute Card File selection dialog 
 

The Apply Early Mute parameter dialog 
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The second process is the computation of the trace autocorrelations.  Select the Autocorrelation 
step from the drop down menu in the Process 2 submenu.  Once the Autocorrelation step has been 
selected, the Parameters… button to the immediate right of the drop down menu will become 
activated requesting user supplied parameters.  In this case, a zero lag time of 0ms will be 
sufficient.  After the Autocorrelation parameter dialog has been completed, click on Apply towards 
the upper left corner of the Seismic Display dialog. 
 

 
 

Second processing step: Autocorrelation 
 
 
 

The Autocorrelation parameter dialog. 
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Application of an early mute and single-channel autocorrelation to the input gather. 
 
At this point we chose to scale down the autocorrelations through the application of a whole-trace, 
single-channel AGC to each of the autocorrelations in order to make them interpretable.  The trace 
length of each of the autocorrelations, which is listed under the Vert Axis tab, is 1196ms.  
Therefore, a single-channel AGC with an AGC window length of 1196ms will be applied.  Once 
the parameterization is correct, click on Apply at the top of the Seismic Display dialog.  Since the 
autocorrelations will be used in the selection of deconvolution parameters, you may wish to 
annotate the display both vertically and horizontally. 
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Final display of single-channel autocorrrelations. 
 

The autocorrelations displayed in the second subview are used to estimate the prediction gap and 
the deconvolution operator length.  For the purpose of this example, the prediction gap and the 
operator length will be set to 24ms and 100ms, respectively, based on analysis of the 
autocorrelations.  To apply predictive deconvolution to the input gather, create a third Seismic 
Bitmap subview and select the same seismic file that is displayed in the previous subviews.  To set 
the processing parameters that will be applied to the third Seismic Bitmap subview, click on the 
Process tab.  First, select the Spherical Divergence Correction step from the drop down menu in the 
Process 1 submenu.  Once the Spherical Divergence step has been selected, the Parameters… 
button to the immediate right of the drop-down menu will become activated requesting user 
supplied parameters.  In this case, the default parameters are sufficient. The second process is 
predictive deconvolution.  Select the Deconvolution step from the drop down menu in the Process 
2 submenu.  Once the Deconvolution step has been selected, the Parameters… button to the 
immediate right of the drop-down menu will become activated requesting user supplied parameters.  
In this case, we will apply a predictive deconvolution with a gap length of 24ms, an operator length 
of 100ms, a design window start time that is defined in an Early Mute card, and a design window 
length of 800ms.  Use the File… button to select the Early Mute function that was previously 
designed on the input gather.  After the Deconvolution parameter dialog has been completed, click 
on OK towards the upper left corner of the Seismic Display dialog. 
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Select the input gather on which to apply deconvolution. 
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First step: Apply spherical divergence correction to the input gather. 
 
 

The Spherical Divergence parameter dialog. 
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Second step: Apply predictive deconvolution to the input gather. 
 

The Deconvolution parameter dialog. 
 

The Early Mute Card File selection dialog. 
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Finally, fully annotate the deconvolved gather. 
 

The application of a spherical divergence correction and single-channel predictive deconvolution. 
 
 
 
To qualify our choice of prediction deconvolution parameters, we will generate a final set of trace-
to-trace autocorrelations that are meant to illustrate both the dereverberation of the individual 
seismograms and the contraction of the seismic wavelet.  To produce this display, create a fourth 
Seismic Bitmap subview and select the same seismic file that is displayed in the previous subviews.  
To set the processing parameters that will be applied to the fourth Seismic Bitmap subview, click 
on the Process tab.  The processing sequence will consist of a spherical divergence correction, 
predictive deconvolution using the previously applied parameters, and single channel 
autocorrelations.   
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Final processing steps: Apply a spherical divergence correction, a 
predicitive deconvolution, and compute autocorrelations. 

 
After each of the relevant parameter dialogs have been completed, click on OK towards the upper 
left corner of the Seismic Display dialog.  The final canvas should look something like the 
following: 
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Final Deconvolution canvas. 
 
 
Try different operator length, gap lengths, and design windows to see what effect they have on the 
resulting output correlations, and always remember to save your work. 
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SeisViewer Applications 
 
This chapter describes specific applications that are ideally performed in SeisViewer.  The 
applications include: 
 

F-K filter design 
 
Mute Picking 
 - Early Mutes 
 - Tail Mutes 
 - Surgical Mutes 
 
Refractor Velocity Analysis 
 
Time Picking 
 - First Break Picking 
 - Event Time Picking 
 
Stacking Velocity Analysis 
 - Hyperbolic Picking 
 - Semblance Picking 
 - Constant Velocity Stack Picking 
 - Delta-T Stack Picking 
 - Horizon Velocity Analysis 
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F-K Filter Design and Application 
 

SeisViewer canvas displaying an input gather with noise (left), it’s F-K spectra (top center), the F-K filtered input 
gather (right), and the F-K spectra of the filtered input gather (bottom center).  

 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  In FlowChart, create a flow similar to the example below.  At a minimum, the flow should 

contain an input data set, an Apply F-K Filter step to apply the F-K filter, and an output 
data set. 

Example flow to apply the F-K filter. 
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Step 2:  In SeisViewer, open a Seismic Bitmap subview, and select the seismic data file that 
contains the input gathers with noise.  Set the horizontal, vertical, and scaling parameters 
as desired.  Annotate with trace header attributes if desired.   

Step 2: Open the seismic file that contains the input gathers with noise. 

 
Step 3: Use the Layer Table to synchronize the seismic gather with the vertical and horizontal 

annotations. 
Step 4: Open a Seismic Grid subview, set the seismic file format to SPW Seismic, the Display 

type to FK Spectrum, and use the Seismic… button to select the SPW file that contains 
the input gathers with noise.  Optional FK spectra parameters can be set by clicking on the 
Options… button located under the Grid tab.  Set the horizontal, vertical, and scaling 
parameters as desired.   

Step 5: F-K filters are implemented as surgical mutes in the F-K domain.  Therefore, set the pick 
file format to FK Mutes, and use the Pick… button to select/create the surgical mute file 
that will contain the FK filter defined by the interactive design session. 

Step 6:  Click OK. 

Step 7: Annotate with vertical (Frequency) and horizontal (Wavenumber) axes. 
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Steps 4-5: Set the seismic file format to SPW Seismic, set the Display type to FK Spectrum, select a 
SPW seismic file to analyze in the FK domain, set the pick file format to FK Mutes, and select/create 
the surgical mute file that will contain the FK filter. 

 
 

Step 7: An annotated F-K spectra generated from the input gather with noise.  
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Step 8:  Pick the F-K spectra to define the F-K filter. To make a filter pick, use the left mouse 

button and select points on the spectra where you would like the filter function.  To edit a 
filter pick, click on the pick with the left mouse button, hold down the button, and drag 
the filter pick to the desired position.  To end the edit, double click with the left mouse 
button.  To delete a filter pick, click once on the pick to select it, and then delete the pick 
with either the Delete Pick command located under the Edit menu, or simply hit Delete on 
the Keyboard. To advance to additional gathers, use the arrow keys.  To save the F-K 
filter function file, select Save Canvas from the File menu. 

 
     

Step 8a: Pick the first point of the F-K filter. Step 8b: Pick the second point of the F-K filter. 
 

 
 

Step 8c: Pick the third point of the F-K filter. Step 8d: Pick the fourth point of the F-K filter. 
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Step 8e: Pick the fifth point of the F-K filter. Step 8f: Double-click the first point to end. 
 
 
Step 9: The resulting FK Mute file can be viewed, and if necessary, refined, by opening the card 

data spreadsheet from the Window tab on the main menu.  
 
 

Step 9a: The FK mute file resulting from the interactive picking session. 
 

Step 9b: An edited FK mute file. 
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Step 10: In FlowChart, apply the F-K filter in Step 9 to the input data. 
 
Step 11: In SeisViewer, open a second Seismic Bitmap subview, and select the seismic data file 

that contains the F-K filtered input gather.  Set the horizontal, vertical, and scaling 
parameters as desired.  Annotate with trace header attributes if desired. 

 

Step 11: Open the seismic file that contains the F-K filtered input gathers.  
 
 
 
Step 12: To further qualify the effects of the F-K filter on the input gather, generate an F-K 

spectrum of the F-K filtered gather.  Open a second Seismic Grid subview, and select the 
SPW file that contains the F-K spectra of the filtered input gathers.  Set the horizontal, 
vertical, and scaling parameters as desired.  Annotate with trace header attributes if 
desired. 

 
 

 
 
 



 156 

 
 
 

Step 13: To further qualify the effects of the F-K filter on the input gather, generate F-K spectra of 
the F-K filtered gather in FlowChart.  Open a fourth Seismic Bitmap subview, set the 
seismic file format to SPW Seismic, the Display type to FK Spectrum, and use the 
Seismic… button to select the SPW file that contains the F-K filtered output gather.  
Optional FK spectra parameters can be set by clicking on the Options… button located 
under the Grid tab.  Set the horizontal, vertical, and scaling parameters as desired.   

 

Step 13: A display of the input gather with noise (left), it’s F-K spectra (top center), the F-K filtered input 
gather (right), and the F-K spectra of the filtered input gather (bottom center). 
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Mute Picking 
 
SeisViewer is designed for the interactive picking of early, surgical, and tail mutes.  Each of these 
picking applications makes use of an intuitive point-and-click interface.  To make a mute pick, use 
the left mouse button to select points on the gather where you would like the mute function.  To 
edit a mute pick, click on the pick with the left mouse button, hold down the button, and drag the 
mute pick to the desired position.  To end the edit, double click with the left mouse button.  To 
delete a mute pick, click once on the pick to select it, and then delete the pick with either the Delete 
Point command located under the Edit menu, or simply hit Delete on the Keyboard.  The arrow 
keys are used to step through the data according to the sort keys that have been set under the File 
tab of the Seismic Display dialog. 

 
Interactive mute picking of pre-stack gathers (Common Source, Common Receiver, Common 
CMP, etc…) requires that the Primary and Secondary sort keys be set according to Line and 
Location of the gather to be picked.  For example, if mute picking is to be performed on CMP 
gathers, then the Primary sort key must be set to CMP Line and the Secondary sort key must be set 
to CMP Location.  The Tertiary sort key will be set to an appropriate value.  In the case of CMP 
gathers, this could be Source-Receiver Offset.  Interactive picking of post-stack mutes will 
generally be performed on stack sections displayed with the Primary sort key set to CMP Line and 
the Tertiary sort key set to CMP Location.  The Secondary sort key will default to None. 
 

As with all other SeisViewer applications, mute picking may be performed on either SPW or SEGY 
data sets.  To begin a picking session, open a Seismic Bitmap subview, set the seismic file format 
(SPW or SEGY) in the Seismic Display dialog, and select the seismic data file using the Seismic… 
button.  In a similar fashion, set the pick file format (Early, Tail, or Surgical Mute) from the 
appropriate drop down menu, and then select/create the pick file using the Picks… button.  This is 
the card data file that will contain the mute functions defined by the interactive picking session. 

 
A Pick options dialog located under the Picking menu gives the user a choice of whether or not to 
display the muted area as a shaded region.  The Pick options dialog also controls the spatial 
interpolation of the mute function between pick locations. 

 
The remainder of the chapter will provide a step-by-step illustration of the interactive picking and 
application of Early, Tail, and Surgical mutes on normal moveout corrected CMP gathers.  Keep in 
mind that each of the mute picking demonstrations is only an example and that SeisViewer mute 
picking tools may be customized to your particular data needs. 
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Early Mute picking 
 

SeisViewer canvas demonstrating the interactive picking and application of an early mute. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open three Seismic Bitmap subviews, each of which will point to the same seismic data 

file.  In this case, that seismic data file will consists of one or a series of CMP gathers.  Set 
the horizontal, vertical, and scaling parameters as desired. 

 
Step 2: Use the Layer Table to synchronize each of the gathers both vertically and horizontally. 

 
Step 3: The first subview will contain a display the uncorrected CMP gather.  Therefore, no 

further processing need be performed on this gather.   
 
Step 4: In the second subview, double-click on the seismic data to bring forth the Seismic Display 

dialog.  Select Early Mute from the pick file formats drop down menu, and name the pick 
file using the Pick… button.  This will be the card data file that contains the early mute 
functions defined by the interactive picking session. 
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Step 4.  Select the seismic data, the mute file, and the mute type. 
 
Step 5: In the Process menu of the Seismic Display dialog corresponding to the second seismic 

bitmap, apply a normal moveout correction using a rough or previously existing velocity 
file.  Select this file with the File… button in the Process 1 submenu.  Turn off the stretch 
mute option in the Parameter… dialog, this will allow the design of an NMO mute 
function on fully NMO corrected CMP gathers.  Once the file and the parameters have 
been set, click on the OK button in the upper left corner of the Seismic Display dialog. 

 

Step 5.  Application of a normal moveout correction under the Process menu. 
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Step 6: Pick the early mute on the moveout corrected gather. To make a mute pick, use the left 
mouse button and select points on the gather where you would like the mute function.  To 
edit a mute pick, click on the pick with the left mouse button, hold down the button, and 
drag the mute pick to the desired position.  To end the edit, double click with the left 
mouse button.  To delete a mute pick, click once on the pick to select it, and then delete 
the pick with either the Delete Pick command located under the Edit menu, or simply hit 
Delete on the Keyboard. To advance to the next gather, use the arrow keys.  To save the 
mute file, select Save Canvas from the File menu. 

 
Step 7: Choose Save Canvas from the File menu to save the early mute file.  Saving the mute file 

is necessary for subsequent application in the third seismic subview. 

Example of an Early Mute card file. 
 
Step 8: In the third subview, double-click on the seismic data to bring forth the Seismic Display 

dialog.  In the Process menu of the Seismic Display dialog set the Process 1 process type 
to Apply Normal Moveout, and select the same velocity function used in the second 
subview.  Be sure to turn off the stretch mute option.  In the Process 2 submenu, set the 
process type to Apply Early mute, and select the early mute file created in the second 
subview with the File… button.  The Parameter… dialog can be used to set the taper 
type and control the taper length of the mute zone.  Once the file and the parameters have 
been set, click on the OK button in the upper left corner of the Seismic Display dialog.  
The muted gather will appear in the third subview. 
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Step 8. Application of the early mute under the Process menu. 
 
 

Step 9: To apply the interactively picked mutes in a FlowChart, select Apply Early Mute from 
Mutes… in the processing list, and link an Early Mute card as shown in the example 
below. 

 

Example flowchart showing the application of an early mute. 
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Tail Mute picking 
 

SeisViewer canvas demonstrating the interactive picking and application of a tail mute. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open three Seismic Bitmap subviews, each of which will point to the same seismic data 

file.  In this case, that seismic data file will consists of one or a series of CMP gathers.  Set 
the horizontal, vertical, and scaling parameters as desired. 

 

Step 2: Use the Layer Table to synchronize each of the gathers both vertically and horizontally. 
 
Step 3: The first subview will contain a display the uncorrected CMP gather.  Therefore, no 

further processing need be performed on this gather.   

 
Step 4: In the second subview, double-click on the seismic data to bring forth the Seismic Display 

dialog.  Select Tail Mute from the pick file formats drop down menu, and name the pick 
file using the Pick… button.  This will be the card data file that contains the tail mute 
functions defined by the interactive picking session.   
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Step 4. Select the seismic data, the mute file, and the mute type. 

 
Step 5: In the Process menu of the Seismic Display dialog corresponding to the second seismic 

bitmap, apply a normal moveout correction using a rough or previously existing velocity 
file.  Select this file with the File… button in the Process 1 submenu.  Turn off the stretch 
mute option in the Parameter… dialog, this will allow the design of the tail mute 
function on fully NMO corrected CMP gathers.  Once the file and the parameters have 
been set, click on the OK button in the upper left corner of the Seismic Display dialog. 

 

Step 5. Application of a normal moveout correction under the Process menu. 
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Step 6: Pick the tail mute on the moveout corrected gather. To make a mute pick, use the left 
mouse button and select points on the gather where you would like the mute function.  To 
edit a mute pick, click on the pick with the left mouse button, hold down the button, and 
drag the mute pick to the desired position.  To end the edit, double click with the left 
mouse button.  To delete a mute pick, click once on the pick to select it, and then delete 
the pick with either the Delete Pick command located under the Edit menu, or simply hit 
Delete on the Keyboard. To advance to the next gather, use the arrow keys.  To save the 
mute file, select Save Canvas from the File menu. 

 
Step 7: Choose Save Canvas from the File menu to save the tail mute file.  Saving the mute file is 

necessary for subsequent application in the third seismic subview. 

Example of a Tail Mute card file. 
 
Step 8: In the third subview, double-click on the seismic data to bring forth the Seismic Display 

dialog.  In the Process menu of the Seismic Display dialog set the Process 1 process type 
to Apply Normal Moveout, and select the same velocity function used in the second 
subview.  Be sure to turn off the stretch mute option.  In the Process 2 submenu, set the 
process type to Apply Tail mute, and select the tail mute file created in the second 
subview with the File… button.  The Parameter… dialog can be used to set the taper 
type and control the taper length of the mute zone.  Once the file and the parameters have 
been set, click on the OK button in the upper left corner of the Seismic Display dialog. 
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Step 8. Application of the tail mute under the Process menu. 
 

Step 9: To apply the interactively picked mutes in a FlowChart, select Apply Tail Mute from 
Mutes… in the processing list, and link a Tail Mute card as shown in the example below. 

 

Example flowchart showing the application of a tail mute. 
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Surgical Mute picking 
SeisViewer canvas demonstrating the interactive picking and application of a surgical mute. 

 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open three Seismic Bitmap subviews, each of which will point to the same seismic data 

file.  In this case, that seismic data file will consists of one or a series of CMP gathers.  Set 
the horizontal, vertical, and scaling parameters as desired. 

 
Step 2: Use the Layer Table to synchronize each of the gathers both vertically and horizontally. 

 
Step 3: The first subview will contain a display the uncorrected CMP gather.  Therefore, no 

further processing need be performed on this gather.   
 
Step 4: In the second subview, double-click on the seismic data to bring forth the Seismic Display 

dialog.  Select Surgical Mute from the pick file formats drop down menu, and name the 
pick file using the Pick… button.  This will be the card data file that contains the tail mute 
functions defined by the interactive picking session. 
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Step 4. Select the seismic data, the mute file, and the mute type. 

 

Step 5: In the Process menu of the Seismic Display dialog corresponding to the second seismic 
bitmap, apply a normal moveout correction using a rough or previously existing velocity 
file.  Select this file with the File… button in the Process 1 submenu.  Turn off the stretch 
mute option in the Parameter… dialog, this will allow the design of the surgical mute 
function on fully NMO corrected CMP gathers.  Once the file and the parameters have 
been set, click on the OK button in the upper left corner of the Seismic Display dialog. 

 

Step 5. Application of a normal moveout correction under the Process menu. 
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Step 6: Pick the surgical mute on the moveout corrected gather. To make a mute pick, use the left 
mouse button and select points on the gather where you would like the mute function.  To 
edit a mute pick, click on the pick with the left mouse button, hold down the button, and 
drag the mute pick to the desired position.  To end the edit, double click with the left 
mouse button.  To delete a mute pick, click once on the pick to select it, and then delete 
the pick with either the Delete Pick command located under the Edit menu, or simply hit 
Delete on the Keyboard. To advance to the next gather, use the arrow keys.  To save the 
mute file, select Save Canvas from the File menu. 

 
Step 7: Choose Save Canvas from the File menu to save the surgical mute file.  Saving the mute 

file is necessary for subsequent application in the third seismic subview. 
 

Example of a Surgical Mute card file. 
 
Step 8: In the third subview, double-click on the seismic data to bring forth the Seismic Display 

dialog.  In the Process menu of the Seismic Display dialog set the Process 1 process type 
to Apply Normal Moveout, and select the same velocity function used in the second 
subview.  Be sure to turn off the stretch mute option.  In the Process 2 submenu, set the 
process type to Apply Surgical mute, and select the surgical mute file created in the 
second subview with the File… button.  The Parameter… dialog can be used to set the 
taper type and control the taper length of the mute zone.  Once the file and the parameters 
have been set, click on the OK button in the upper left corner of the Seismic Display 
dialog. 
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Step 8. Application of the tail mute under the Process menu. 

 

Step 9: To apply the interactively picked mutes in a FlowChart, select Apply Surgical Mute from 
Mutes… in the processing list, and link a Surgical Mute card as shown in the example 
below. 

 

Example flowchart showing the application of a surgical mute. 
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Refractor Velocity Picking 
 

SeisViewer canvas demonstrating the interactive picking of refractor velocities from first-break times. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview.  Set the File format to SPW Seismic and use the 

Source… button to select a seismic data file appropriate for picking refractor velocities 
from first break arrival times.  
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Step 1.  Select the seismic File format and the input file name. 

 
Step 2:  Select Refraction Velocity from the pick file formats drop down menu in the Seismic 

Display dialog, and select/create the file that will contain the layer-location-velocity picks 
defined by the interactive picking session. 

 

Step 2.  Select the pick File format and the pick file name. 
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Step 3: When you select an SPW file for refractor velocity picking the sort keys must be set to 
one of three configurations:  
 
Common Source configuration 

Primary  - Source Line  
Secondary - Source Location 

Tertiary  - Source-Receiver Offset 
 

Common Receiver configuration 
Primary  - Receiver Line  

Secondary - Receiver Location 
Tertiary  - Source-Receiver Offset 

 
Common Midpoint configuration 

Primary  - CMP Line  
Secondary - CMP Location 

Tertiary  - Source-Receiver Offset 
 

In this example, we will work with the Common Source configuration.  Set the display 
parameters as desired. Set the horizontal, vertical, and scaling parameters as desired  

 
Step 4: Click OK in the upper left corner of the Seismic Display dialog to and the seismic bitmap 

display will appear.  Annotate with vertical, horizontal, and trace header attributes as 
desired. 

 
Step 5: Use the Layer Table to synchronize each of seismic gathers with the vertical and 

horizontal annotations. 
 

Step 6:  Pick the refractor velocity corresponding to the first layer. To make a velocity pick, use 
the left mouse button and select a first-arrival time corresponding to the near-offset 
portion of the refractor. To complete a velocity pick, use the left mouse button and select 
a first-arrival time corresponding to the far-offset portion of the refractor.  To edit a 
velocity pick, click on the pick with the left mouse button, hold down the button, and drag 
the velocity pick to the desired position.  To end the edit, double click with the left mouse 
button.  To delete a velocity pick, click once on the pick to select it, and then delete the 
pick with either the Delete Pick command located under the Edit menu, or simply hit 
Delete on the Keyboard.  To save the velocity file, select Save Canvas from the File 
menu.
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Step 6.  Select the first point on the refractor. 
 
 

 
Step 6.  Select the second point on the refractor.  The velocity of this layer will 
appear in the lower-left corner of the SeisViewer canvas. 

 
 
Step 7:  Pick refractor velocities corresponding to additional layers.  Additional refractor velocity 

picks are made by selecting additional pairs of first-arrival times, and the values of each 
layer will be written to the Card data file with a sequentially updated layer number. 
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Step 7.  Refractor velocity pick for layer two. 
 

Step 7.  Refractor velocity pick for layer three. 
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Step 8: Continue picking refractor velocities until the all layers have been picked.  Use the arrow 
keys to step forward to the next gather you wish to pick.   

 
Step 9:  Save the refractor velocity card data file by saving the canvas. 
 

Example of a Refractor Velocity card file. 
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Time Picking 
 
SeisViewer is designed for the interactive picking of first break times and event times.  Each of 
these picking applications makes use of an intuitive point-and-click interface.  
 

A Pick Options dialog located under the Picking menu allows seismic arrivals to be picked on 
either a trace-to-trace basis or on a linear-guided basis.  The same dialog provides options for 
automatic picking of seismic arrivals on the peak, on the trough, on the zero crossing, or without 
regard to a sample attribute.  Finally, in the case of first break time picking, the time picks from the 
previous or the next gather may be displayed as a reference for picking first breaks on the current 
gather. 

 
To make a time pick, use the left mouse button to select points on the display where you would like 
the pick.  If you are using the linear-guided picking option, use the mouse button to select the first 
and last points to be picked.  If the mouse button is held down on the last point, a visual rubber 
band will stretch between the two points that indicates where the algorithm will search for seismic 
arrivals.  All the traces between the two points will be picked automatically based on the Pick Type 
criteria selected in the Pick Options dialog.  To edit a single time pick, click on the pick with the 
left mouse button, hold down the button, and drag the time pick to the desired position.  If signal-
to-noise considerations prevent the picker from placing the time pick according to the Pick Type 
criteria, you will want to change the Pick Type to “No event detection”.  The “No event detection” 
criteria will allow you to place the pick wherever you click the left mouse button.  To end the time 
picking of a given layer, double click with the left mouse button.  This will cause subsequent picks 
to be identified with another layer.  To delete a time pick, click once on the pick to select it, and 
then delete the pick with either the Delete Point command located under the Edit menu, or simply 
hit Delete on the Keyboard.  The arrow keys are used to step through the data according to the sort 
keys that have been set under the File tab of the Seismic Display dialog. 

 
As with all other SeisViewer applications, time picking may be performed on either SPW or SEGY 
data sets.  To begin a picking session, open a Seismic Bitmap subview, set the seismic file format 
(SPW or SEGY) in the Seismic Display dialog, and select the seismic data file using the Seismic… 
button.  In a similar fashion, set the pick file format (First Break Times or Event Time Picks) from 
the appropriate drop down menu, and then select/create the pick file using the Picks… button.  This 
is the card data file that will contain the time picks defined by the interactive picking session. 
 

The remainder of the chapter will provide a step-by-step illustration of the interactive picking of 
first break times on a shot gather and event times on a stacked seismic section. Keep in mind that 
each of the time picking demonstrations is only an example and that SeisViewer time picking tools 
may be customized to your particular data needs. 
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First Break Picking 
 

SeisViewer canvas demonstrating the interactive picking of first-break arrival times. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a seismic data file appropriate for picking 

first break arrival times.  Set the horizontal, vertical, and scaling parameters as desired.  
Annotate with Receiver elevations or other trace header attributes if desired.   

 
Step 2: Use the Layer Table to synchronize each of seismic gathers with the vertical and 

horizontal annotations. 
 
Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

First Break Times from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This will be the card data file that contains the first break 
time picks defined by the interactive picking session. 

 
Step 4: Open the Pick Options… dialog under the Picking menu.  Set the Pick Method to Linear 

guided picking.  Set the Pick Type to Detect peak (or as appropriate). 
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Step 5: Select a first-break arrival with the left mouse button.  

Step 5.  Selection of the first-break arrival time on Channel 1. 
 
Step 6: Select a second first-break arrival with the left mouse button. Hold down the cursor to 

make the interconnecting rubber band visible. 
 

Step 6.  Select the second first-break arrival time and hold down cursor.  The 
rubber band will appear between picks. 
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Step 7: Release the mouse button and each of the traces between the two points will be picked 
automatically based on the Pick Type criteria selected in the Pick Options dialog 

Step 7.  Select the second first-break arrival time and hold down cursor.  The 
rubber band will appear between picks. 

 
 
Step 8: To end the picking of a layer, double-click on the last pick of the layer.  Subsequent picks 

will be annotated on the screen in a different color and the pick times will be place in the 
Card data file with a sequentially updated layer number. 

 
Step 9: Continue selecting first breaks until the all arrivals in the gather have been selected.  Once 

all arrivals in the gather have been selected, use the arrow keys to step forward to the next 
gather.  Proceed with picking until all gathers in the survey have been picked. 

 
Step 10: Save the time picks by saving the canvas. 
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Example of a First Break Time Picks card file. 
 
Step 9: To apply the interactively picked first break arrivals in a FlowChart, select Apply Early 

Mute from Mutes… in the processing list, and link an Early Mute card as shown in the 
example below. 

 

Example flowchart showing the use of first break times in the computation of refraction statics. 
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Event Picking 

SeisViewer canvas demonstrating the interactive picking of seismic horizons on a stacked section. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a seismic data file appropriate for picking 

event times.  Set the horizontal, vertical, and scaling parameters as desired.  Annotate with 
a trace header plot if desired.   

 

Step 2: Use the Layer Table to synchronize each of seismic gathers with the vertical and 
horizontal annotations. 

 
Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

Event Time Picks from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This will be the card data file that contains the first break 
time picks defined by the interactive picking session. 

 
Step 4: Open the Pick Options… dialog under the Picking menu.  Set the Pick Method to Linear 

guided picking.  Set the Pick Type to Detect peak (or as appropriate). 
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Step 5: Select an event on one of the stacked traces with the left mouse button.  

Step 5.  Selection of the event time on the first trace of the stacked section. 
 
Step 6: Select the same event on another one of the stacked traces with the left mouse button.  

Hold down the cursor to make the interconnecting rubber band visible. 
 

Step 6.  Select the second event time and hold down cursor.  The rubber band will 
appear between picks. 

 
Step 7: Release the mouse button to automatically pick each event time between the 

two selected traces. 
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Step 7.  Each event between the two pick traces is automatically picked upon release of the mouse button. 
 
Step 8: Pick all event times from the first trace to the last trace.  Double click on the last trace to 

complete the picking of the layer.  After double clicking, the event picks will change color 
and you are ready to pick the next event. 

Step 8.  Double click on the last trace to complete picking the layer.  The event picks will change color 
and you may begin picking the next horizon. 
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Step 9: Pick the remaining events. 
 

Step 9.  Proceed with picking additional horizons. 
 
Step 10:  Save the time picks by saving the canvas. 
 

Example of a Horizon File. 
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Stacking Velocity Analysis 
 
SeisViewer provides a very flexible environment for the interactive analysis of stacking velocities 
by means of eta semblance spectra, gamma semblance spectra, velocity semblance spectra, constant 
velocity stacks, hyperbolic moveout picking, delta-t stacks, and horizon velocity analysis.  Each of 
these picking applications makes use of an intuitive point-and-click interface.  To make a velocity 
pick, use the left mouse button to select points on the seismic bitmap where you would like the 
velocity function.  To edit a velocity pick, click on the pick with the left mouse button, hold down 
the button, and drag the velocity pick to the desired position.  To end the edit, double click with the 
left mouse button.  To delete a velocity pick, click once on the pick to select it, and then delete the 
pick with either the Delete Point command located under the Edit menu, or simply hit Delete on the 
Keyboard.  The arrow keys are used to step through the data according to the sort keys that have 
been set under the File tab of the Seismic Display dialog. 

 
The remainder of the chapter will provide a step-by-step illustration of the interactive picking and 
application of stacking velocity functions by means reflection hyperbola, the various semblance 
spectra, constant velocity stacks, delta-T stacks, and horizon velocity analysis.  Keep in mind that 
each of these demonstrations is only an example and that SeisViewer velocity analysis tools may be 
customized to your particular data needs. 
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Hyperbolic Velocity Analysis 
 

SeisViewer canvas demonstrating velocity analysis through the interactive picking of reflection hyperbolas (left) 
and the resulting velocity field (right). 

 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a seismic data file appropriate for picking 

reflection hyperbolas.  When you select an SPW file for hyperbola picking the sort keys 
must be set to one of three configurations:  
Common Source configuration 

Primary  - Source Line  
Secondary - Source Location 

Tertiary  - Source-Receiver Offset 
 

Common Receiver configuration 
Primary  - Receiver Line  

Secondary - Receiver Location 
Tertiary  - Source-Receiver Offset 
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Common Midpoint configuration 
Primary  - CMP Line  

Secondary - CMP Location 
Tertiary  - Source-Receiver Offset 

 
Set the display parameters as desired.  Annotate with the appropriate horizontal, vertical 
and trace header attributes.  

 

Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 
annotations. 

 
Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

Hyperbolic from the pick file formats drop down menu, and select/create the pick file 
using the Pick… button.  This will be the card data file that contains the time-velocity 
picks defined by the interactive picking session. 

Step 3.  Select the seismic data, the velocity file, and the velocity type. 
 
Step 4: Open the Pick Options… dialog under the Picking menu.  If checked, reflection hyperbola 

from either the previous or the next gather may be displayed as a reference for picking 
reflection hyperbola on the current gather. 

Step 4.  The Velocity Pick Options dialog. 
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Step 5: Select a point on a reflection hyperbola with the left mouse button. 

 
 

Step 5.  Selection of a point on a reflection hyperbola with the mouse button. 
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Step 6: Select a second point on a reflection hyperbola with the left mouse button, then release the 
button.  The hyperbola passing between these two points will be displayed in green on the 
seismic bitmap and the moveout velocity corresponding to the hyperbola will be placed in 
the velocity file with the appropriate zero-offset time. 

 

Step 6.  Select a second point on the reflection hyperbola and release the mouse button.  The 
corresponding reflection hyperbola will appear. 
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Step 7: Select each reflection hyperbola on the gather for which you desire a velocity-time pair in 
the velocity file. 

 
Step 8: Select all gathers in the data set for which you desire a velocity function 
 
Step 9: Choose Save Canvas from the File menu to save the velocity file.  Saving the velocity file 

is necessary to display the velocity field. 
 
Step 10: Open a Seismic Grid subview.  Set the Source file format to SPW Seismic and select a 

previously generated stacked seismic section using the Source… button.  The trace header 
values in this stacked section are used as a reference for the velocity field.  Set the Source 
Display type to Velocity.   

Step 10.  Select a reference stack, and set the display type. 
 
 

Step 11: Click on the Options… button to open the Velocity Model Options dialog.  Use the 
Browse button in the Velocity Model Options dialog to select the Hyperbolic velocity file 
created in Steps 1-9.  To display the stacking velocity field, check Display velocity pick 
locations. 

Velocity Model Options dialog. 
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Step 12: Once the Hyperbolic velocity file and the display options have been specified, click OK in 
the Velocity Model Options dialog, followed by OK in the upper left corner of the Grid 
Display.  The stacking velocity field determined through interactive analysis of reflection 
hyperbola will be displayed in the Seismic Grid subview. 

 

Step 12: Velocity field display. 
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The velocity functions determined through interactive picking of reflection hyperbola are applied 
by linking a Velocity card data file to the Apply Normal Moveout step as shown in the example 
flowchart. 

 
 
 

Application of hyperbolic velocity picks. 
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Semblance Velocity Analysis 
 

SeisViewer canvas for velocity analysis through the interactive picking of semblance spectra (left) generated 
from CMP gathers (center) and the resulting velocity field (right). 

 
 
There are two methods available for creating and picking semblance gathers such as the one 
displayed on the left in the figure above.  In the first method, semblance gathers are generated from 
CMP gathers in Flowchart and output as an SPW formatted seismic file.  These semblance gathers 
are then loaded into SeisViewer as a Seismic Bitmap display.  In the second method, semblance 
gathers are generated in SeisViewer directly from CMP gathers that are loaded into a SeisViewer 
Grid display.  In each case the parameterization that controls the generation of semblance gathers is 
identical.  Method #1 will be described first followed by method #2. 
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Velocity Semblance Gathers from FlowChart 
 
Step 1:  Open a Seismic Bitmap subview, and select a SPW formatted semblance file generated by 

the Velocity Semblance step in FlowChart. When you select an SPW file output by the 
Velocity Semblance step the sort keys will default to:  

 
Primary - CMP Line 

Secondary - CMP Location 
Tertiary - Velocity 

 
Set the color scheme of the semblance spectra as desired.  Annotate with the appropriate 
horizontal, vertical, color bar, and trace header attributes. 

 

Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 
annotations. 

 
Step 3: Double-click on the semblance data display to bring forth the Seismic Display dialog.  

Select Semblance from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This will be the card data file that contains the time-velocity 
picks defined by the interactive picking session.  Click OK in the upper left corner of the 
Seismic Display dialog, and then Save the canvas. 

 

Step 3.  Select the semblance data, the velocity file, and the velocity type. 
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Step 4: Open a second Seismic Bitmap subview, and select the SPW formatted file of uncorrected 
CMP gathers that was input to the Velocity Semblance step in FlowChart.  Set the 
horizontal, vertical and scaling parameters as desired.  Annotate with the appropriate 
horizontal, vertical and trace header attributes. 

Step 4.  Select the CMP gather seismic file used to generate the semblance spectra. 
 
Step 5: In the Process menu of the Seismic Display dialog corresponding to the seismic bitmap 

that contains the CMP gathers apply a normal moveout correction using the velocity file 
being currently being picked on the adjacent semblance gather.  Select this file with the 
File… button in the Process 1 submenu.  Use the Parameter… dialog to set the stretch 
mute to a desired value.  Once the file and the parameters have been specified, click on 
the OK button in the upper left corner of the Seismic Display dialog. 

 

Step 5.  Apply a normal moveout correction to the CMP gathers with velocity currently being 
picked on the adjacent semblance spectra. 
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Step 6: Link the horizontal scroll groups between the semblance display and the CMP gather 
display.  Once linked, a pick on the semblance spectra may be qualified by viewing the 
moveout on the corresponding CMP gather. 

 
Step 7: Select Pick Traces from the Picking menu. 
 
Step 8: Open the Pick Options… dialog under the Picking menu.  If checked, velocity functions 

from either the previous or the next semblance gather may be displayed as a reference for 
picking a velocity function on the current semblance gather. 

Velocity Pick Options dialog 
 

Step 9: Pick the semblance spectra to define a velocity function. To make a semblance pick, use 
the left mouse button and select points on the spectra where you would like the velocity 
function.  To edit a velocity pick, click on the pick with the left mouse button, hold down 
the button, and drag the velocity pick to the desired position.  To end the edit, double click 
with the left mouse button.  To delete a velocity pick, click once on the pick to select it, 
and then delete the pick with either the Delete Pick command located under the Edit 
menu, or simply hit Delete on the Keyboard. To advance to the next gather, use the arrow 
keys.  To save the velocity file, select Save Canvas from the File menu. 
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Step 9.  Select time-velocity pairs on the spectra with the mouse button. 

Step 9 (cont).  Complete the selection time-velocity pairs by double-clicking with the mouse button. 
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Step 10: Select velocity functions for each semblance spectra in the data file. 
 
Step 11: Choose Save Canvas from the File menu to save the velocity file. 
 
Step 12: Open a Seismic Grid subview.  Set the Source file format to SPW Seismic and select a 

previously generated stacked seismic section using the Source… button.  The trace header 
values in this stacked section are used as a reference for the velocity field.  Set the Source 
Display type to Velocity.   
 
 

Step 12.  Select a reference stacked section and set the Display type to Velocity. 
 
 

Step 13: Click on the Options… button to select a velocity file.  Use the Browse button in the 
Velocity Model Options dialog to select the Semblance velocity file created in Steps 1-8.  
To display the stacking velocity field, check Display velocity pick locations. 

 

Step 13.  The Velocity Model Options dialog. 
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Step 14: Once the Semblance velocity file and the display options have been specified, click OK in 
the Velocity Model Options dialog, followed by OK in the upper left corner of the Grid 
Display.  The stacking velocity field determined through interactive analysis of semblance 
spectra will be displayed in the Seismic Grid subview.  Annotate horizontally and 
vertically as desired. 

 

Step 14.  Display of the stacking velocity field picked through interactive analysis of the semblance spectra.  
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The velocity functions determined through interactive picking of semblance gathers are applied by 
linking a Velocity card data file to the Apply Normal Moveout step as shown in the example 
flowchart. 

 
 

Application of semblance gather velocity picks. 
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Velocity Semblance Gathers in SeisViewer 
 
Step 1: Open a Seismic Grid subview, set the File format to SPW Seismic and the Display type 

format to Velocity Semblance.  Use the Source… button to select the file of uncorrected 
CMP gathers that will be used in the semblance analysis.  Set the pick file format to 
Velocity Semblance and create/select the velocity file that will contain the time-velocity 
picks defined by the interactive picking session. 

Step 1: Select file format, the display type, and the CMP gathers for semblance analysis. 
 
Step 2: Open the Velocity Semblance dialog by clicking on the Options… button in the Grid 

Display dialog.  The Velocity Semblance dialog is used to set parameters for the 
semblance analysis.  Once the parameters have been specified, click on the OK button at 
the bottom of the Velocity Semblance dialog, followed by the OK button in the upper-left 
corner of the Grid Display dialog.  The velocity semblance gather will be generated. 

 

Step 2: Set parameters in the Velocity Semblance dialog. 
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Step 3: Open a second Seismic Bitmap subview, and select the SPW formatted file of uncorrected 
CMP gathers that was input to the Velocity Semblance step in Step 1.  Set the horizontal, 
vertical and scaling parameters as desired.  Annotate with the appropriate horizontal, 
vertical and trace header attributes. 

Step 3.  Select the CMP gather seismic file used to generate the semblance spectra. 
 
Step 4: In the Process menu of the Seismic Display dialog corresponding to the seismic bitmap 

that contains the CMP gathers apply a normal moveout correction using the velocity file 
being currently being picked on the adjacent semblance gather.  Select this file with the 
File… button in the Process 1 submenu.  Use the Parameter… dialog to set the stretch 
mute to a desired value. Once the file and the parameters have been specified, click on the 
OK button in the upper left corner of the Seismic Display dialog.  Optionally, you may 
apply a Sliding Window AGC for display. 

 

Step 4.  Apply a normal moveout correction to the CMP gathers with velocity currently being 
picked on the adjacent semblance spectra. 

 



 203 

Step 5: Link the horizontal scroll groups between the semblance display and the CMP gather 
display.  Once linked, a pick on the semblance spectra may be qualified by viewing the 
moveout on the corresponding CMP gather. 

 
Step 6: Select Pick Traces from the Picking menu. 
 
Step 7: Open the Pick Options… dialog under the Picking menu.  If checked, velocity functions 

from either the previous or the next semblance gather may be displayed as a reference for 
picking a velocity function on the current semblance gather. 

 

Velocity Pick Options dialog 
 
Step 8: Pick the velocity semblance spectra to define a velocity function. To make a semblance 

pick, use the left mouse button and select points on the spectra where you would like the 
velocity function.  To edit a velocity pick, click on the pick with the left mouse button, 
hold down the button, and drag the velocity pick to the desired position.  To end the edit, 
double click with the left mouse button.  To delete a velocity pick, click once on the pick 
to select it, and then delete the pick with either the Delete Pick command located under 
the Edit menu, or simply hit Delete on the Keyboard.  To save the velocity file, select 
Save Canvas from the File menu. 
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Step 8.  Select time-velocity pairs on the spectra with the mouse button. 

Step 8 (cont).  Complete the selection time-velocity pairs by double-clicking with the mouse button. 
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Step 9: Select velocity functions for each semblance spectra in the data file. 
 
Step 10: Choose Save Canvas from the File menu to save the velocity file. 
 
Step 11: Open a Seismic Grid subview.  Set the Source file format to SPW Seismic and select a 

previously generated stacked seismic section using the Source… button.  The trace header 
values in this stacked section are used as a reference for the velocity field.  Set the Source 
Display type to Velocity.   
 
 

Step 12.  Select a reference stacked section and set the Display type to Velocity. 
 
 

Step 12: Click on the Options… button to select a velocity file.  Use the Browse button in the 
Velocity Model Options dialog to select the Semblance velocity file created in Steps 1-8.  
To display the stacking velocity field, check Display velocity pick locations. 

 

Step 13.  The Velocity Model Options dialog. 
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Step 13: Once the Semblance velocity file and the display options have been specified, click OK in 
the Velocity Model Options dialog, followed by OK in the upper left corner of the Grid 
Display.  The stacking velocity field determined through interactive analysis of semblance 
spectra will be displayed in the Seismic Grid subview.  Annotate horizontally and 
vertically as desired. 

 

Step 13.  Display of the stacking velocity field picked through interactive analysis of the semblance spectra.  
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The velocity functions determined through interactive picking of semblance gathers are applied by 
linking a Velocity card data file to the Apply Normal Moveout step as shown in the example 
flowchart. 

 
 

Application of semblance gather velocity picks. 
 
 

 
 

 



 208 

Constant Velocity Stack Analysis 
 

SeisViewer canvas for velocity analysis through the interactive picking of constant velocity stacks. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a SPW formatted file generated by the 

Constant Velocity Stacks step in FlowChart.  When you select an SPW file output by the 
Constant Velocity Stacks step the sort keys will default to:  
 

Primary - Velocity Panel 
Secondary - Velocity 

Tertiary - CMP Location 
 

Set the display parameters as desired.  Annotate with the appropriate horizontal, vertical 
and trace header attributes.   

 
Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 

annotations. 
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Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

Constant Velocity from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This will be the card data file that contains the time-velocity 
picks defined by the interactive picking session.  Click OK in the upper left corner of the 
Seismic Display dialog. 

 
 

Step 3.  Select the constant velocity stack data, the velocity file, and the velocity type. 
 
Step 4: Select Pick Traces from the Picking menu. 

 
Step 5: Open the Pick Options… dialog under the Picking menu.  If checked, velocity functions 

from either the previous or the next panel of constant velocity stacks may be displayed as 
a reference for picking a velocity function on the current panel of constant velocity stacks. 

 

Velocity Pick Options dialog. 
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Step 6: Pick the constant velocity stacks to define a velocity function. To make a pick, use the left 
mouse button and select points on any of the stack panels where you would like the 
velocity function.  To edit a velocity pick, click on the pick with the left mouse button, 
hold down the button, and drag the velocity pick to the desired position.  To end the edit, 
double click with the left mouse button.  To delete a velocity pick, click once on the pick 
to select it, and then delete the pick with either the Delete Pick command located under 
the Edit menu, or simply hit Delete on the Keyboard. To advance to the next gather, use 
the arrow keys.  To save the velocity file, select Save Canvas from the File menu. 
 

Step 6.  Select time-velocity pairs on the constant velocity stacks with the mouse button. 
 

 
 

Step 7: Save the velocity file by selecting Save Canvas from the File menu 
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The example flowcharts in the figures below illustrate the generation of constant velocity stacks 
(left) and the application of velocities picked from constant velocity stacks (right). 
 
 
 

Generation of constant velocity stacks  Application of velocities picked from constant velocity stacks 
 
 
 



 212 

Constant Eta Stack Analysis 
 

SeisViewer canvas for Eta analysis through the interactive picking of constant Eta stacks. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a SPW formatted file generated by the 

Constant Eta Stacks step in FlowChart.  When you select an SPW file output by the 
Constant Eta Stacks step the sort keys will default to:  

 
Primary - Eta Panel 

Secondary - Eta 
Tertiary - CMP Location 

 
Set the display parameters as desired.  Annotate with the appropriate horizontal, vertical 
and trace header attributes.   

 

Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 
annotations. 
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Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

Constant Eta from the pick file formats drop down menu, and select/create the pick file 
using the Pick… button.  This will be the card data file that contains the time-eta picks 
defined by the interactive picking session.  Click OK in the upper left corner of the 
Seismic Display dialog. 

 
 

Step 3.  Select the constant Eta stack data, the velocity file, and the velocity type. 
 
Step 4: Select Pick Traces from the Picking menu. 

 
Step 5: Open the Pick Options… dialog under the Picking menu.  If checked, Eta functions from 

either the previous or the next panel of constant Eta stacks may be displayed as a 
reference for picking an Eta function on the current panel of constant Eta stacks. 

 

Eta Pick Options dialog. 
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Step 6: Pick the constant Eta stacks to define an Eta function. To make a pick, use the left mouse 
button and select points on any of the stack panels where you would like the Eta function.  
To edit an Eta pick, click on the pick with the left mouse button, hold down the button, 
and drag the Eta pick to the desired position.  To end the edit, double click with the left 
mouse button.  To delete an Eta pick, click once on the pick to select it, and then delete 
the pick with either the Delete Pick command located under the Edit menu, or simply hit 
Delete on the Keyboard. To advance to the next gather, use the arrow keys.  To save the 
Eta file, select Save Canvas from the File menu. 
 

Step 6.  Select time-eta pairs on the constant Eta stacks with the mouse button. 
 

 
 

Step 7: Save the Eta file by selecting Save Canvas from the File menu 
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The example flowcharts in the figures below illustrate the generation of constant Eta stacks (left) 
and the application of Non-hyperbolic moveout using Eta functions picked from constant Eta stacks 
(right). 
 
 

   

Generation of constant Eta stacks.   
 
 
 
 
 
 
 

Application of non-hyperbolic moveout using Eta functions picked from constant Eta stacks. 
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Constant Gamma Stack Analysis 
 

SeisViewer canvas for Gamma analysis through the interactive picking of constant gamma stacks. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a SPW formatted file generated by the 

Constant Gamma Stacks step in FlowChart.  When you select an SPW file output by the 
Constant Gamma Stacks step the sort keys will default to:  

 
Primary - Gamma Panel 

Secondary - Gamma 
Tertiary - CMP Location 

 
Set the display parameters as desired.  Annotate with the appropriate horizontal, vertical 
and trace header attributes.   

 

Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 
annotations. 
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Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

Constant Gamma from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This will be the card data file that contains the time-eta 
picks defined by the interactive picking session.  Click OK in the upper left corner of the 
Seismic Display dialog. 

 
 

Step 3.  Select the constant Gamma stack data, the velocity file, and the velocity type. 
 
Step 4: Select Pick Traces from the Picking menu. 

 
Step 5: Open the Pick Options… dialog under the Picking menu.  If checked, Gamma functions 

from either the previous or the next panel of constant Gamma stacks may be displayed as 
a reference for picking an Gamma function on the current panel of constant Gamma 
stacks. 

 

Gamma Pick Options dialog. 
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Step 6: Pick the constant Gamma stacks to define a Gamma function. To make a pick, use the left 
mouse button and select points on any of the stack panels where you would like the 
Gamma function.  To edit an Gamma pick, click on the pick with the left mouse button, 
hold down the button, and drag the Gamma pick to the desired position.  To end the edit, 
double click with the left mouse button.  To delete an Gamma pick, click once on the pick 
to select it, and then delete the pick with either the Delete Pick command located under 
the Edit menu, or simply hit Delete on the Keyboard. To advance to the next gather, use 
the arrow keys.  To save the Gamma file, select Save Canvas from the File menu. 
 

Step 6.  Select time-gamma pairs on the constant Gamma stacks with the mouse button. 
 

 
 

Step 7: Save the Gamma file by selecting Save Canvas from the File menu 
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The example flowcharts in the figures below illustrate the generation of constant Gamma stacks 
(left) and the application of Non-hyperbolic moveout using Gamma functions picked from constant 
Gamma stacks (right). 
 
 

   

Generation of constant Gamma stacks.   
 
 
 
 
 
 
 

Application of converted-wave non-hyperbolic moveout using Gamma functions picked from constant Gamma stacks. 
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Delta-T Stack Velocity Analysis 
 

SeisViewer canvas for velocity analysis refinement through the interactive picking of delta-t stacks. 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, and select a SPW formatted file generated by the Delta-

T Stacks step in FlowChart. When you select an SPW file output by the Delta-T Stacks 
step the sort keys will default to:  

 
Primary - Velocity Panel 

Secondary - Source-Receiver Offset 
Tertiary - CMP Location 

 
Set the display parameters as desired.  Annotate with the appropriate horizontal, vertical 
and trace header attributes. 

 

Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 
annotations. 
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Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 

Delta T Velocity from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This will be the card data file that contains the time-velocity 
picks defined by the interactive picking session.   

 

Step 3.  Select the Delta T stack data, the velocity file, and the velocity type. 
 
Step 4: Open the DeltaT Pick Options dialog with the Options… button.  The DeltaT Pick 

Options dialog allows selection of the reference velocity field used to generate the delta-T 
stacks in FlowChart.  Make sure to select the same velocity file and set the Maximum 
offset to the same value used to generate the delta-T stacks in FlowChart.  Finally, select 
whether velocity functions from either the previous or the next panel of constant velocity 
stacks will be displayed as a reference for picking a velocity function on the current panel 
of delta-T stacks. Click OK in the DeltaT Pick Options dialog, followed by OK in the 
upper left corner of the Seismic Display dialog. 

 

Step 4.  The DeltaT Pick Options dialog 
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Step 5: Select Pick Traces from the Picking menu. 
 
Step 6: Pick the Delta T velocity stacks to define a velocity function. To make a pick, use the left 

mouse button and select points on any of the stack panels where you would like the 
velocity function.  To edit a velocity pick, click on the pick with the left mouse button, 
hold down the button, and drag the velocity pick to the desired position.  To end the edit, 
double click with the left mouse button.  To delete a velocity pick, click once on the pick 
to select it, and then delete the pick with either the Delete Pick command located under 
the Edit menu, or simply hit Delete on the Keyboard. To advance to the next gather, use 
the arrow keys.  To save the velocity file, select Save Canvas from the File menu. 
 

Step 6.  Select time-deltaT pairs on the Delta T stacks with the mouse button. 
 
 
 
 
Step 7: Save the velocity file by selecting Save Canvas from the File menu. 
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The example flowcharts in the figures below illustrate the generation of constant delta-T stacks 
(left) and the application of velocities picked from constant delta-T stacks (right). 
   
 

Generation of constant velocity stacks  Application of velocities picked from constant velocity stacks 
 
 

 



 224 

Horizon Velocity Analysis 
 

SeisViewer canvas for velocity analysis of specified horizons (right) through interactive picking of the corresponding 
horizon consistent semblance scans (left). 
 
To create a SeisViewer canvas similar to the figure above, perform the following steps: 
 
Step 1:  Open a Seismic Bitmap subview, set the file format to SPW Seismic and select a stack file 

that contains the horizons to be analyzed. When you select an SPW formatted stack file 
the sort keys will default to:  

 
Primary - CMP Line 

Secondary - (none) 
Tertiary - CMP Location 

 
Set the display parameters as desired.  Annotate with the appropriate horizontal, vertical 
and trace header attributes. 

 

Step 2: Use the Layer Table to synchronize the seismic display with the vertical and horizontal 
annotations. 
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Step 3: Double-click on the seismic data display to bring forth the Seismic Display dialog.  Select 
Event Time Picks from the pick file formats drop down menu, and select/create the pick 
file using the Pick… button.  This card data file will contain the horizon picks used to 
control the generation of horizon consistent semblance spectra for the horizon velocity 
analysis. 

Step 3.  Select the stack section, the pick file format, and the pick file name. 
 
Step 4: Pick the horizons as described in the chapter on Time Picking. 

Step 4.  Pick each horizon for velocity analysis. 
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Step 5: Save the event picks by selecting Save Canvas from the File menu.  *After the event 
picks have been saved, return to the Seismic Bitmap dialog and deselect the event pick 
file by setting the pick file format to None.  

 
Step 6: Open a Seismic Grid subview, and select the SPW formatted file of uncorrected CMP 

gathers that will be used in the horizon velocity analysis.  Set the Display type to HOVA 
(horizon velocity analysis).  

Step 6.  Select the stack section, the horizon pick file, and the pick type. 
 

Step 7: Open the Horizon Velocity Analysis dialog by clicking on the Options… button in the 
Grid Display dialog.  The Horizon Velocity Analysis dialog is used to (1) set parameters 
for the horizon velocity analysis; (2) select the horizon file that will control the analysis; 
(3) create/pick the velocity file that will contain the time-velocity picks defined by the 
interactive picking session. Once the files and the parameters have been specified, click 
on the OK button in the lower left corner of the Horizon Velocity Display dialog. 

 

Horizon Velocity Analysis dialog 
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Step 8: Select HOVA Velocity from the pick file formats drop down menu in the Grid Display 
dialog, and select/create the file that will contain the horizon-velocity picks defined by the 
interactive picking session.  This file will be an Event Time Pick format and the name 
should be different from that of the velocity file defined in the Horizon Velocity Analysis 
dialog in Step 7. 

 
Step 9: Click OK in the upper left corner of the Grid Display dialog.  The horizon consistent 

semblance spectra used for the horizon velocity analysis will be generated. Annotate with 
the spectra horizontally and vertically. 
 

Step 9.  Horizon consistent semblance spectra (right) generated for the second horizon on the stack section 
(left) 
 

Step 10: Pick the semblance spectra to define a velocity function. To make a semblance pick, use 
the left mouse button and select points on the spectra where you would like the velocity 
function.  To edit a velocity pick, click on the pick with the left mouse button, hold down 
the button, and drag the velocity pick to the desired position.  To end the edit, double click 
with the left mouse button.  To delete a velocity pick, click once on the pick to select it, 
and then delete the pick with either the Delete Pick command located under the Edit 
menu, or simply hit Delete on the Keyboard.  To save the velocity file, select Save Canvas 
from the File menu. 

 
Step 11: Generate addition horizon consistent semblance spectra, one per horizon, as described 

above. 
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Step 11.  Horizon consistent semblance spectra (right) generated for each of the horizons on the stack section 
(left). 

 
Step 12: Save the velocity file by selecting Save Canvas from the File menu 

 
The velocity file output by SeisViewer at the end of the picking session will contain the collated 
picks for each of the picked horizons.  In the case of a two horizon picking session, the output file 
will look like the following: 

HOVA Velocity file 



 229 

Eta Semblance Non-hyperbolic Velocity Analysis 
 

SeisViewer canvas demonstrating P-wave Eta analysis through the interactive picking of Eta semblance spectra 
(right).  Non-hyperbolic NMO using the Eta function picked on the right is applied to the corresponding CMP 
gather (left). 
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Step 1: Open a Seismic Grid subview, set the File format to SPW Seismic and the Display type 
format to Eta Semblance.  Use the Source… button to select the file of uncorrected CMP 
gathers that will be used in the Eta semblance analysis.  Set the pick file format to Eta 
Semblance and create/select the Eta file that will contain the time-eta picks defined by the 
interactive picking session. 

Step 1: Select file format, the display type, and the CMP gathers for eta semblance analysis. 
 
Step 2: Open the Eta Semblance dialog by clicking on the Options… button to the right of the 

Display type field in the Grid Display dialog. .  The Eta Semblance dialog is used to set 
parameters for the semblance analysis and select the corresponding P-wave small-spread 
stacking velocity function.  The P-wave small-spread stacking velocity file is selected 
with the Browse button.  It is not necessary that the Eta functions be picked at the same 
locations as the functions in the P-wave stacking velocity file.  Once the parameters have 
been specified, click on the OK button at the bottom of the Eta Semblance dialog, 
followed by the OK button in the upper-left corner of the Grid Display dialog.  The Eta 
semblance gather will be generated. 

Step 2: Set parameters in the Eta Semblance dialog. 
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 Step 3: Open a second Seismic Bitmap subview, and select the SPW formatted file of uncorrected 
CMP gathers that was input to the Eta Semblance dialog in Step 1.  Set the horizontal, 
vertical and scaling parameters as desired.  Annotate with the appropriate horizontal, 
vertical and trace header attributes. 

Step 3.  Select the CMP gather seismic file used to generate the Eta semblance spectra. 
 
 Step 4: In the Process menu of the Seismic Display dialog corresponding to the seismic bitmap 

that contains the CMP gathers choose Apply PP non-hyperbolic moveout for Process 1. 
The PP non-hyperbolic moveout correction uses a combination of the P-wave small-
spread velocity field referenced by the adjacent Eta semblance display and the time-eta 
functions being interactively picked on the adjacent Eta semblance display.  Select the Eta 
file with the File… button in the Process 1 submenu.  Use the Parameter… dialog to 
select the corresponding P-wave stacking velocity function and set the stretch mute. Once 
the file and the parameters have been specified, click on the OK button in the upper left 
corner of the Seismic Display dialog.  Optionally, you may apply a Filter and Sliding 
Window AGC for display. 

  

Step 4.  Apply PP non-hyperbolic moveout correction to the CMP gathers with the Eta 
functions currently being picked on the adjacent eta-semblance spectra. 



 232 

 
Step 5: Link the horizontal scroll groups between the semblance display and the CMP gather 

display.  This will allow the CMP gather and the Eta semblance gather to advance in 
unison during the picking session.  Once linked, a pick on the semblance spectra may be 
qualified by viewing the moveout on the corresponding CMP gather. 

 
 
Step 6: Pick the Eta semblance spectra to define an Eta function. To make a semblance pick, use 

the left mouse button and select points on the spectra where you would like the Eta 
function.  To edit an Eta pick, click on the pick with the left mouse button, hold down the 
button, and drag the Eta pick to the desired position.  To end the edit, double click with 
the left mouse button.  To delete a Eta pick, click once on the pick to select it, and then 
delete the pick with either the Delete Pick command located under the Edit menu, or 
simply hit Delete on the Keyboard.  To save the Eta file, select Save Canvas from the File 
menu. 

 
 

Step 6.  Select time-eta pairs on the spectra with the mouse button. 
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Step 6 (cont).  Complete the selection time-eta pairs by double-clicking with the mouse button. 
 
 

Step 7: Pick Eta functions for each semblance spectra in the data file. 
 
Step 8: Choose Save Canvas from the File menu to save the velocity file. 
 

 
The Eta functions determined through interactive picking of Eta-semblance gathers are applied by 
linking a PP Nhmo Eta Function card data file to the Apply PP Nonhyperbolic Moveout step as 
shown in the example flowchart. 

 

The application of Non-hyperbolic Moveout. 
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Gamma Semblance Non-hyperbolic Velocity Analysis 
 

SeisViewer canvas demonstrating PS-wave gamma analysis through the interactive picking of gamma semblance 
spectra (right).  Converted-wave non-hyperbolic moveout using the gamma function picked on the right is applied 
to the CMP gather (left). 
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Step 1: Open a Seismic Grid subview, set the File format to SPW Seismic and the Display type 
format to Gamma Semblance.  Use the Source… button to select the file of uncorrected 
converted-wave CMP gathers that will be used in the gamma semblance analysis.  Set the 
pick file format to Gamma Semblance and create/select the gamma file that will contain 
the time-gamma picks defined by the interactive picking session. 

Step 1: Select file format, the display type, and the CMP gathers for gamma semblance analysis. 
 
Step 2: Open the Gamma Semblance dialog by clicking on the Options… button to the right of 

the Display type field in the Grid Display dialog. .  The Gamma Semblance dialog is used 
to set parameters for the semblance analysis and select the corresponding P-wave stacking 
velocity function.  The P-wave velocity file is selected with the Browse button.  It is not 
necessary that the Gamma functions be picked at the same locations as the functions in the 
P-wave stacking velocity file.  Once the parameters have been specified, click on the OK 
button at the bottom of the Gamma Semblance dialog, followed by the OK button in the 
upper-left corner of the Grid Display dialog.  The gamma semblance gather will be 
generated. 

Step 2: Set parameters in the Gamma Semblance dialog. 
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 Step 3: Open a second Seismic Bitmap subview, and select the SPW formatted file of uncorrected 
converted wave CMP gathers that was input to the Gamma Semblance dialog in Step 1.  
Set the horizontal, vertical and scaling parameters as desired.  Annotate with the 
appropriate horizontal, vertical and trace header attributes. 

Step 3.  Select the converted-wave CMP gather seismic file used to generate the gamma semblance spectra. 
 
 Step 4: In the Process menu of the Seismic Display dialog corresponding to the seismic bitmap 

that contains the CMP gathers choose Apply PS non-hyperbolic moveout for Process 1. 
The PS non-hyperbolic moveout correction uses a combination of the P-wave velocity 
field referenced by the adjacent gamma semblance display and the time-gamma functions 
being interactively picked on the adjacent gamma semblance display.  Select the gamma 
file with the File… button in the Process 1 submenu.  Use the Parameter… dialog to 
select the corresponding P-wave stacking velocity function and set the stretch mute. Once 
the file and the parameters have been specified, click on the OK button in the upper left 
corner of the Seismic Display dialog.  Optionally, you may apply a Filter and Sliding 
Window AGC for display. 

  

Step 4.  Apply PS non-hyperbolic moveout correction to the converted-wave CMP gathers 
with the gamma currently being picked on the adjacent gamma-semblance spectra. 
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Step 5: Link the horizontal scroll groups between the semblance display and the CMP gather 

display.  This will allow the CMP gather and the gamma semblance gather to advance in 
unison during the picking session.  Once linked, a pick on the semblance spectra may be 
qualified by viewing the moveout on the corresponding CMP gather. 

 
 
Step 6: Pick the gamma semblance spectra to define a gamma function. To make a semblance 

pick, use the left mouse button and select points on the spectra where you would like the 
gamma function.  To edit a gamma pick, click on the pick with the left mouse button, hold 
down the button, and drag the gamma pick to the desired position.  To end the edit, double 
click with the left mouse button.  To delete a gamma pick, click once on the pick to select 
it, and then delete the pick with either the Delete Pick command located under the Edit 
menu, or simply hit Delete on the Keyboard.  To save the gamma file, select Save Canvas 
from the File menu. 

 
 
 

Step 6.  Select time-gamma pairs on the spectra with the mouse button. 
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Step 6 (cont).  Complete the selection time-gamma pairs by double-clicking with the mouse button. 
 
 

Step 7: Pick gamma functions for each semblance spectra in the data file. 

 
Step 8: Choose Save Canvas from the File menu to save the velocity file. 
 

 
The gamma functions determined through interactive picking of gamma-semblance gathers are 
applied by linking a Velocity card data file to the Apply PS Nonhyperbolic Moveout step as shown 
in the example flowchart. 

 

The application of Non-hyperbolic Moveout. 
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SeisViewer Installation 
 
  
 
 


